Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I own a Line6 UX1 soundcard and I would like to make it work for Ubuntu.
I have followed the instructions here and it worked.

But at some point I upgraded my kernel version (not sure what uname -a prints but it's related) and it stopped working.

Here's what uname -a prints:

Linux ubuntu 2.6.32-29-generic #58-Ubuntu SMP Fri Feb 11 20:52:10 UTC 2011 x86_64 GNU/Linux

I figured out that maybe it's installed per version so I used svn update and hit make again. My guess was right as it copied the relevant files to the new version's folder. I restarted and still nothing.
Should I revert to an older version? Or is there a solution here?

share|improve this question
add comment

1 Answer

Install dkms package. After that all your drivers will be rebuilt every time you update your kernel.

share|improve this answer
    
@Asmerito: Should I just type apt-get install dkms? Also, what do I do with the current situation? –  the_drow Feb 19 '11 at 3:25
    
@Asmerito: It's already installed and up to date. What's next? –  the_drow Feb 19 '11 at 3:28
    
hmm it has no dkms.config file. How do I make one? –  the_drow Feb 19 '11 at 3:43
    
I really have no idea about dkms.config. dkms will compile every driver for new vesion of kernel automatically on boot. Maybe your source code must be in /usr/src folder? Try to find more where dkms search for source code. linuxtv.org/wiki/index.php/Mantis_with_DKMS might help –  Asmerito Feb 27 '11 at 9:16
    
@Asmerito: Well you have to configure it in order for it to work. dkms ignores everything that doesn't have dkms.config –  the_drow Mar 5 '11 at 18:27
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.