Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just wiped my Dell Latitude's E6410's hard drive and installed ubuntu-12.04-desktop-amd64.iso. The wireless connection kept timing out, but the wired connection is perfectly fine.

I already tried to

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source

but it did not solve the problem.

Output of lspci:

03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wwireless LAN Controller (rev 01)

Output of sudo lshw -c network:

*-network               
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth2
       version: 01
       serial: 5c:ac:4c:14:f4:dd
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:e6e00000-e6e03fff

Output of nm-tool (sorry about the formatting, this is inputted by hand)

Device: eth2 [Belkin_e18584]

Type:        801.11 WiFi
Driver:      wl
State:       connecting (configuring)
Default:     no
HW Address:  5C:AC:4C:14:F4:DD

Capabilities:

Wireless Properties
WEP Encrypion:  yes
WPA Encrypion:  yes
WPA2 Encrypion: yes
share|improve this question
    
I have the same computer and wireless worked flawless. Do you have the same problem using other dirstos? –  sebwen Mar 19 '13 at 8:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.