Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I figured out a way to transcode my videos so that they would play at double speed using the GUI as "Convert/Stream" --> "Show More options" and adding :rate=2.0 after :file-caching=300 in the "Edit Options" box. Where exactly do I put this :rate=2.0 when I am transcoding my video using command-line?

For eg:

vlc -vvv "my video.avi" :sout="#transcode{width=320,canvas-height=240,vcodec=mp4v, vb=768, acodec=mp4a, ab=96, channels=2}:std{access=file, mux=mp4, url=myvideo.mp4}" vlc:quit

Where do I put :rate=2.0 ??

I am doing this so that I can use a bash script to batch-convert video lectures so that I can play them on my ipod at double speed.

share|improve this question

Try:

vlc --rate=2.00 -vvv "my video.avi" --sout .......
share|improve this answer
    
Didn't work. The following happened: code shikhar@shikhar-HP-Pavilion-dv2000:~$ vlc --rate-2.00 -vvv "/home/shikhar/Videos/psy.flv" :sout="#transcode{width=320,canvas-height=240,vcodec=mp4v, vb=768, acodec=mp4a, ab=96, channels=2}:std{access=file, mux=mp4, url=myvideo.mp4}" vlc:quit vlc: unknown option or missing mandatory argument --rate-2.00' Try vlc --help' for more information. – Shikhar Nigam Jul 3 '13 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.