Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed ubuntu 12.04 on my machine, but I am not able to use wi-fi in ubuntu. Actually there is a toggle button to turn on the wifi and when the wifi is ON an LED will glow. But all the time I presses that button it don't glow.

So I tried installing the driver form the solution suggested in question: How do I install BCM43142 wireless drivers for Dell Vostro 3460/3560

since the wifi device on my machine is also Broadcom Corporation Device [14e4:4365]. I got the driver successfully installed but still I am not able to turn on the wifi means the LED not glows.

Also here are the output of some commands which might be helpful

lshw -C network

*-network UNCLAIMED
   description: Network controller
   product: Broadcom Corporation
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list
   configuration: latency=0
   resources: memory:f1900000-f1907fff

and iwconfig

lo        no wireless extensions.

usb0      no wireless extensions.

here usb0 is what I am using with my mobile connected with data cable to access internet.

And rfkill list

0: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: dell-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no

Also one more thing when I toggle the wifi button off the rfkill list gives both in blocked mode.

Please help... Thanks.

share|improve this question
    
rebooted the system? or try deb file from here - jas.gemnetworks.com/debian/pool/main/w as mentioned in askubuntu.com/questions/55868/… –  Web-E Mar 19 '13 at 5:20
    
ok, i didn't tried rebooting after driver installation. Anyways I will check today if it is working. –  codeomnitrix Mar 19 '13 at 6:22
    
Sometimes rebooting really works :D :P –  codeomnitrix Mar 19 '13 at 16:07
1  
yes, after installation you have to either execute modprobe <driver_name> or reboot. :) –  Web-E Mar 19 '13 at 16:14

1 Answer 1

Problem Solved! I also had same kind of problem and it got soled by executing the following commands for reinstalling the driver

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source
share|improve this answer
    
Hi Krishna, I got the wifi drivers installed sometime back but I was not able to use Aircrack. will try this one. –  codeomnitrix Feb 14 at 8:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.