Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to install libtorrent-rasterbar 0.14.10 on Ubuntu 12.04.

This has been suggested to me as a solution to problems using Deluge behind a VPN.

I have tried adding an older Deluge PPA but that produced broken packages. I also tried installing the from source, but got the following error in Terminal:

configure: error: We could not detect the boost libraries (version 1.34 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See for more documentation.

This my first question here, so please go easy and thanks in advance for any tips.

share|improve this question
The error message that you got when attempting to install from source was referring to the fact that you probably did not have the (excellent) Boost C++ libraries installed on your machine. Try running sudo apt-get install libboost-dev and then attempting to re-compile. – InkBlend Mar 18 '13 at 23:39
Thanks very much for this answer. I just need to figure out how to modify the ./configure command to direct it to my boost C++ installation and I should be there. – user141491 Mar 19 '13 at 21:55
That will not work, as per my answer, you need to install boost 1.49 or lower. – Cas Mar 19 '13 at 22:29

Did you already try the package libtorrent-rasterbar6? It is available in the Ubuntu repository and it packages libtorrent-rasterbar 0.15.10 in Ubuntu 12.04.

sudo apt-get install libtorrent-rasterbar6

Any reason for versions other than 0.14.10 don't work?

share|improve this answer
Thanks for the answer. Yes, I tried that. I am trying to downgrade the package to 0.14.10 because it may be causing problems with a VPN service I am using, see: Unfortunately it appears that 0.14.10 isn't in the repos, hence my trying to compile from source. – user141491 Mar 19 '13 at 21:42

You will need to install a boost version that is 1.49 or lower.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.