Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a strange problem with keyboard shortcuts. After turning on my computer (or rebooting), and logging in, shortcuts don't work. To get them working, I have to log out and log in again. Then everything is all right. There's another problem. I have access to TTY-s 1-6 only just after reboot (and logging in for the first time). When I log out (to make Xfce shortcuts working), I loose access to my TTY-s. There's a blank screen instead.

I think that there might be a key conflict. But I don't use any shortcut combination which uses CTRL+ALT at the same time. I have a NVIDIA graphics card.

I put a line:

Option "HandleSpecialKeys" "always"

in the section "ServerLayout" (I tried before in ServerFlags) in /etc/X11/xorg.conf but it didn't helped (firstly I wanted to fix ttys, being unaware of desktop shortcuts problem)

An issue with blank screen on CTRL+ALT+F1-F6 happens also after waking up from a suspend state. To get access to TTY 1-6 after loosing it, I have to reboot my computer.

Thanks for any ideas.

share|improve this question
    
OKAY, fixed, by installing noveau FREE driver. Sometimes, proprietary doesnt mean better ;) I dont play games, soo... :) please mark it as solved or something –  MikeD Mar 20 '13 at 15:25
    
Mike, please post that as an answer, then you can mark it solved. –  Jorge Castro Mar 20 '13 at 15:37
add comment

1 Answer

up vote 2 down vote accepted

Ok, I've found out how to make TTY-s working after a suspend, login etc. Firstly, I thought that the reason is the Power Manager. Actually, the reason was quite different. Installing xserver-xorg-video-nouveau and connected packages, instead of NVidia Current driver, helped. I had Nvidia driver version 304, and I'm not sure about the new version, 310; if it's better or not. As far as shortcuts are concerned, I've also replaced in my keyboard shortcut file (/home/mpd/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml) all "Control" entries with "Primary".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.