Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi I'm very new to Ubuntu 12.04 LTS and having installed it on albeit an old laptop I have found it to be very slow. I have a feeling this is more likely to do with my hardware but I'd appreciate any help that could be offered.

My system runs (fully up to date) Ubuntu 12.04 LTS on 1.7GiB RAM, AMD Athlon(tm) Processor 2650e, Gallium 0.4 on ATI RS690, 64bit and has 80GB of disk space (dual boot experiment). While I didn't expect it to be lightning fast I'm still surprised how 'laggy' my machine is running (32bit XP running on the same spec runs perfectly).

My apologies if I've made some elementary mistakes of this is a repeat question, would just love to get Ubuntu to work for me.

Linux Hanbuntu 3.2.0-39-generic #62-Ubuntu SMP Thu Feb 28 00:28:53 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

“/usr/lib/nux/unity_support_test -p” results in the following:

OpenGL vendor string:   X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS690
OpenGL version string:  2.1 Mesa 8.0.4

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

“sudo lshw -C video” reveals the following:

       description: VGA compatible controller
       product: RS690M [Radeon X1200 Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 5
       bus info: pci@0000:01:05.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=64
       resources: irq:43 memory:d0000000-dfffffff memory:f0100000-f010ffff ioport:9400(size=256) memory:f0000000-f00fffff

“sudo hdparm -Tt /dev/sda” provides the following:

Timing cached reads:   1474 MB in  2.00 seconds = 736.99 MB/sec
    Timing buffered disk reads: 182 MB in  3.01 seconds =  60.47 MB/sec

“sudo hdparm -v /dev/sda” provides:

 multcount     = 16 (on)
 IO_support    =  1 (32-bit)
 readonly      =  0 (off)
 readahead     = 256 (on)
 geometry      = 19457/255/63, sectors = 312581808, start = 0
share|improve this question

try installing lxde in the terminal by typing sudo apt-get install lxde. Lxde is a much lighter desktop environment, try installing preload by typing sudo apt-get install preload

Disable start up applications and make sure all your drivers are installed.

This is optional but I think 32-bit will be better on your machine.

I hope this helps.

share|improve this answer
Might sound silly, but how do you check all your drivers are installed? (as I said very new). I ran the 'Additional Drivers' prog from the Systems Settings screen but it found nothing. – Chortle Mar 18 '13 at 19:44
Go to the terminal and type in lshw that will give you a list of installed drivers and then the ones that aren't there you can install. I don't know what drivers you would exactly need sorry. – Goku Mar 18 '13 at 19:50
Drivers appear to be installed? Tried upping RAM to 4GB but with little effect. Could the processor be the bottleneck? – Chortle Mar 19 '13 at 9:39
It's a Single core 1.6GHz? AMD 64 2650e – Chortle Mar 19 '13 at 9:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.