Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before I upgraded to 12.10, I was able to mount my shares automatically. They're located on an Amahi Home Server running Fedora 14. I'm able to access them without any problems via PacManFM (I'm using Lubuntu), but when I try to mount them permanently via /etc/fstab, I get

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

My lines in /etc/fstab look like this (there's four shares that I'm mounting)

# Adding networked drives 3-18-13
//hda/Music /home/patrickdickey/Music cifs credentials=/home/patrickdickey/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0  
//hda/Movies /home/patrickdickey/Videos cifs credentials=/home/patrickdickey/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0  
//hda/patrickdickey /home/patrickdickey/myhda cifs credentials=/home/patrickdickey/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0  
//hda/Docs /home/patrickdickey/DocsHDA cifs credentials=/home/patrickdickey/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0  
//hda/Books /home/patrickdickey/Books cifs credentials=/home/patrickdickey/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0 

which is pretty much straight out of the community help page for mounting a windows share permanently.

I checked dmesg | tail (and /var/log/kern.log) and got these responses

[   52.680033] FS-Cache: Loaded
[   52.764054] FS-Cache: Netfs 'cifs' registered for caching
[   52.764242] Key type cifs.spnego registered
[   52.764262] Key type cifs.idmap registered
[   52.765794] CIFS: no cache= option specified, using "cache=loose". This default will change to "cache=strict" in 3.7.
[   52.912035] CIFS VFS: default security mechanism requested.  The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
[   54.107070] CIFS VFS: cifs_mount failed w/return code = -13
[   54.120041] CIFS VFS: cifs_mount failed w/return code = -13
[   54.121778] CIFS VFS: cifs_mount failed w/return code = -13
[   54.135672] CIFS VFS: cifs_mount failed w/return code = -13
[   54.138654] CIFS VFS: cifs_mount failed w/return code = -13

I'm at a loss. My .smbcredentials file shows

username=myusername
password=mypassword

and I've tried adding

domain=DICKEY

which is the name of the workgroup that it's assigned to. But nothing works.

I'm able to mount them manually, if I use

sudo mount -t cifs //hda/Movies /home/patrickdickey/Videos -o username=patrickdickey,password=mypassword,uid=1000,gid=1000

But, if I change the username=,password= to credentials= and use my .smbcredentials file, I get the Permission Denied error.

I THINK the problem is that my password begins with a :, but I'm not sure how to fix that in the credentials file (especially since it works when I put it in manually). In fact, I'm pretty sure this is the problem, as changing the lines in /etc/fstab to username=patrickdickey,password=mypassword works fine (with sudo mount -a).

So, I guess my main question is, how to I pass the : in my password via the credentials file? (For reference, let's say my password is :DoGWalK3r --which it's not even close to).

Any help with this is greatly appreciated.

Have a great day.:) Patrick.

share|improve this question
1  
Does it work if you wrap the password with single quotes? –  Mordoc Mar 18 '13 at 17:03
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.