Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with the Realtek RTL8723E like so many others, but in my case it simply refuses to connect. I am running Ubuntu 12.10 with the latest patches and kernel.

I referred to this excellent thread: Wireless card Realtek RTL8723AE-BT is not recognized to try to install the Realtek Wireless card on a new laptop - the Zoostorm W251EU. I have tried everything in the thread but the network manager simply shows 'Wireless networks' greyed out and disconnected.

Oddly enough this worked before on kernel 3.5.0-25 ... but after a reboot yesterday stopped working and has not worked since.

  1. Hardware switch - works, and it is on

  2. sudo lshw -C network output

    *-network               
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 20:68:9d:dc:fe:25
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723e driverversion=3.5.0-26-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 ioport:e000(size=256) memory:f7d00000-f7d03fff
    
  3. rfkill list shows no hardware or software blocks

  4. My blacklist is empty

  5. Driver: rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012 appears to make and install fine, but does not work any more. This worked previously with the 0-25 kernel (the problem appeared before the kernel upgrade to 0-26, I redid all the steps after installing kernel 0-26 in the hope it would start working again)

  6. I'm running Windows 7 x64 inside VirtualBox, have tried to play with the network settings just in case there's some interference. No joy.

share|improve this question
add comment

1 Answer 1

I have one of these laptops and it is working for me (albeit slowly) on 3.5.0-27-generic.

Did you try a

make clean

This will clear out all the old object files before making the driver with.

make
sudo make install

Failing this working try removing the directory and then untaring the driver and doing:

make
make install
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.