Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed lucid on my Lenevo Laptop (Y 410 series , x86 platform) and it is working fine. Now I have compiled kernel 2.6.37 downloaded from the kernel tree. I followed usual procedure of compiling kernel (make menuconfig, make, make modules etc). Then I created the initrd image using mkinitramfs and updated my grub using update-grub command.

update-grub detects the initrd image of the compiled kernel. However when I boot from this kernel it gives me following error:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! root=UUID=/... does not exist. Dropping to a shell!

BusyBox v1.19.3 (Ubuntu 1:1.10.3-7ubuntu1.1) built-in shell (ash)
Enter 'help' for a lost of built-in commands.
(initramfs)

and then it falls onto initramfs prompt.

I have tried following solutions discussed in different Ubuntu forums:

  1. disable uuid and point root=/dev/sda8 (sda8 is where my kernel image resides (both default kernel and compiled one) from /etc/default/grub
  2. compile kernel using CONFIG_DEVTMPFS=y suggested here Still I am unable to boot from the compile kernel.

Could someone please suggest me the solution?

share|improve this question

2 Answers 2

I suggest using KernelCheck for this, it makes it very easy to compile the kernel with just a few clicks.

share|improve this answer

root= should be root disk partition (where / filesystem is), not a boot partition.

Are you sure you compiled in the drivers for your disk controller and root filesystem?

share|improve this answer
    
I am talking about root parameter in grub config file.When I write GRUB_DISABLE_LINUX_UUID=true in /etc/default/grub , it passes root=/dev/sda8 as parametr to grub. I verfied this by pressing 'e' in grub2 on both the kernels. Now problem is default kernel boots and compiled does not. –  user11053 Feb 18 '11 at 10:15
    
About compilation of drivers , I am using make menuconfig and not disableing any driver. Doesnt it mean it shoul compile all the required drivers ? –  user11053 Feb 18 '11 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.