Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in between suspend and awake my system of course drops its wlan connection. Then once awakend from its suspend notwork-manager tries to reestablish the connection. All works fine , I think

BUT: doing the same on my dual-boot win-8 system is so much faster (wlan + with it internet is there instantly <1sec) on my Ubunut it takes 10+ seconds or more.

What could be a way to check for problems in network-mangager? or any other way to "bring it to speed" (it must be possible, as even win8 does it!)

update

looking for the gap in /var/log/syslog I can see already a "huge" (at least annoying 4 sec time gap in between (see yourself):

Mar 18 08:52:22 freak NetworkManager[1428]:  (wlan0): supplicant interface state: disconnected -> scanning
Mar 18 08:52:26 freak wpa_supplicant[1717]: Trying to authenticate with c0:25:06:c6:b4:fe (SSID='mywlan_essid' freq=2472 MHz)

who is so slow?

share|improve this question
    
Alternatively, anybody knows a good tutorial to use cmdline tools to setup wlan easily/ automatically? –  humanityANDpeace Mar 18 '13 at 7:15

1 Answer 1

I experience exactly the same issue, although my gap is 10 seconds long.

Sep 12 13:38:28 jumbo NetworkManager[1139]: <info> (wlan2): supplicant interface state: disconnected -> scanning
Sep 12 13:38:38 jumbo wpa_supplicant[1715]: wlan2: Trying to associate with 00:15:c7:29:86:81 (SSID='MILANO' freq=2412 MHz)

Unfortunately, I could not find any docs about the different interface states, so I can only guess what the "scanning" state means: Your computer listens for other Access Points with the same SSID and connects to the AP with the best signal quality.

Therefore, I believe this issue could be solved, if we would be able to set a static entry and hereby controll to which AP your computer should connect, this at least would be a solution for your workplace / home etc... As far as I know, nmcli does not offer this option right now, as you can only tell to which SSID you want to connect to. This could be scripted and used as a cronjob:

sudo nmcli device wifi connect "${SSID}" iface "${iface}"

Another solution might modify the duration of this annoying gap to a much lower value, but I doubt that this value is configurable right now.

share|improve this answer
1  
Welcome to Ask Ubuntu Skyo! This is a great analysis, however, there isn't really a "concrete" answer there, so it doesn't solve the question. Have you tried running that nmcli command at startup? Did it reduce the gap? –  Alaa Ali Sep 17 '13 at 14:48
    
You are completely right, my answer is incomplete. I could not find any way to reduce the gap, furthermore the gap exist not only during startup but also while switching from one network to another. However I want to point out, that I believe that there is no way to accomplish this, hence that is the reason for my analysis rather than an "concrete" answer. –  Oyks Livede Sep 17 '13 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.