Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to rescue a friend's computer. Put Ubuntu 12.10 on a Flash drive, changed the boot order, and fired it up; no problem. But now that I'm in, I can't seem to find the internal drive!

Any thoughts? I ran sudo fdisk -l in the Terminal and got this:

Disk /dev/sdb: 15.6 GB, 15610576896 bytes

119 heads, 55 sectors/track, 4658 cylinders, total 30489408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot     Start         End      Blocks  Id  System
/dev/sdb1   *       8064    30489407    15240672   c  W95 FAT32 (LBA)

99% sure that's the flash drive; it's 16GB. If that is the internal drive, I'm just not sure how to mount it. When I tried to mount /dev/sdb1 /mnt/point it told me mount: only root can do that.

share|improve this question
    
Have you tried using sudo at the beginning of the command? –  Lucio Mar 18 '13 at 0:51
    
@Lucio - oh man, was hoping that wasn't my problem :P I re-ran it with sudo and didn't get an error, but I went into mnt/point and looked at the contents and it really looks like my flash drive's contents. It has wubi.exe and stuff in it; it's identical to the contents of the cdrom folder. So I can pretty confidently say it's not my internal hard drive. –  Brendan Mar 18 '13 at 0:57
1  
Ehh, you usually have to mount the internal drive when booting from a liveUSB. If you open up the file manager do you see any extra drives? –  Seth Mar 18 '13 at 0:59
    
Is really that all the output of the command? To compare, this is my output. –  Lucio Mar 18 '13 at 1:01
    
@Lucio - edited to add the output above the drive list. –  Brendan Mar 18 '13 at 1:04

2 Answers 2

The few times I've done that sort of thing, I used Puppy linux, (newer version is called Slacko), and previous to that Knoppix and AntiX, which were supposed to be better at "finding" hard drives. Best, and easiest way to make a USB, in my opinion,is to use LinuxLive. If the drive is readable, should show up on the desktop in the lower left corner, and you can just click on it. Hope this helps.

share|improve this answer
up vote 1 down vote accepted

See the comments for more info on this question, but I think the only real problem was that the hard drive is damaged. Reboots and prayer were the only thing making it go...we'd reboot, see it mounted, copy some stuff, then it would presumable hit a bad sector, freeze/go gray, and disappear until we rebooted again.

share|improve this answer
    
But did you mounted/used/see the HDD in any time or not? –  Lucio Mar 18 '13 at 22:19
1  
Yeah, it appeared in the File Manager as I would have expected upon rebooting. We were able to get some of the files off, but then we'd hit a bad sector and then the drive would either unmount, stop showing files, or just stop copying files. –  Brendan Mar 18 '13 at 23:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.