Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04.2 LTS x86_64 with two mismatched monitors: one, a laptop @ 1366x768 native, the other an Asus @ 1920x1080 native res. How can I enter fullscreen with mednafen displaying on just one monitor, leaving the other one untouched? The problem with just hitting atl+enter after booting up a game normally is my large display shrinks and both monitors mirror (and stay mirrored afterward).

This is just a pain and passing arguments like -pcfx.xres 1366 -pcfx.yres 768 from a bash script just results in the game being displayed across both monitors. If anyone has some tips that I could learn from, it'd be appreciated.

Edits: if it helps, compizconfig is set to detect my outputs (display settings).

Here is the output when running a game via bash script

Initializing sound...
 Using "ALSA" audio driver with SexyAL's default device selection.ALSA Error: snd_pcm_open(&alsa_pcm, id ? id : "hw:0", SND_PCM_STREAM_PLAYBACK, 0) Device or resource busy
Error opening a sound device.
Initializing video...
 Video Driver: OpenGL
 Video Mode: 3286 x 1080 x 32 bpp
  Pixel shader: none
 Fullscreen: Yes
 Special Scaler: None
 Scanlines: Off
 Destination Rectangle: X=922, Y=60, W=1440, H=960
 OpenGL Implementation: Tungsten Graphics, Inc Mesa DRI Intel(R) Ironlake Mobile  2.1 Mesa 8.0.4
 Checking extensions:
  GL_ARB_texture_non_power_of_two found.
 Using non-power-of-2 sized textures.
 Checking maximum texture size...
  Apparently it is at least: 8192 x 8192
 Using GL_BGRA, GL_UNSIGNED_INT_8_8_8_8_REV for texture source data.
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Set these environment variables as shown, in your bash script, before running mednafen, and it will full screen only on the primary display.

export SDL_VIDEO_FULLSCREEN_DISPLAY=0
export SDL_VIDEO_FULLSCREEN_HEAD=0

You may also need to update the configuration in ~/.mednafen/mednafen.cfg to not have the very large resolution specifications set, had they been set to the large values previously.

share|improve this answer
    
Hmm, still results in mednafen spanning both monitors. –  DiabolicalClaptrap Mar 17 '13 at 22:53
    
I appreciate the help, but I'm still unable to work this. Like you suggested, I edited x and yres in mednafen.cfg.. no go. –  DiabolicalClaptrap Mar 19 '13 at 19:47
    
Ok, I went ahead and fixed it myself. Turns out I had to set pce scaling options to their default values. Works great. Thanks. :) –  DiabolicalClaptrap Mar 19 '13 at 20:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.