Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install the webkit applicaion from sources using this manual:

https://help.ubuntu.com/community/WebKit

When I type:

./autogen.sh --prefix=/usr

the following error occurs:

checking for _FILE_OFFSET_BITS value needed for large files... 64
configure: error: Compiler GCC >= 4.7 or Clang >= 3.0 is required for C++ compilation

When I type:

gcc --version

It responds:

gcc (Ubuntu/Linaro 4.7.2-11precise2) 4.7.2

Hence the error does not concern gcc version. Why the execution fails?

Edited: Previous problem is solved by updating g++ to 4.7. But the following error occurs further:

checking for GAIL... no
configure: error: Package requirements (gail-3.0 >= 3.0) were not met:

No package 'gail-3.0' found 

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GAIL_CFLAGS
and GAIL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have apt-get install gail-3.0, but the error remains.

Edited: Also did:

apt-get install gail-3.0-dev
apt-get build-dep webkit

But further missing packages revealed: error: Package requirements (libsoup-2.4 >= 2.40.0) were not met:

Requested 'libsoup-2.4 >= 2.40.0' but version of libsoup is 2.38.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBSOUP_CFLAGS
and LIBSOUP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
share|improve this question
    
My guess is your G++ is older than your gcc –  hbdgaf Mar 17 '13 at 22:40
    
you are right!! –  Сашко Лихенко Mar 17 '13 at 22:41
3  
apt-get install gail-3.0-dev. Why don't you just apt-get build-dep whatever package contains webkit instead of fighting with this? –  hbdgaf Mar 18 '13 at 5:27
1  
Agreed with @AbrahamVanHelpsing. Please read through the help document you linked to, it gives you a list of what to do, including what you need to install. –  Thomas W. Mar 18 '13 at 6:20
2  
show 8 more comments

1 Answer 1

The PPA mentioned in the question is greatly outdated for 12.04 hence you have to disable it and find another instructions on building webkit from source. Additionally, someone has to edit the wiki.

Looks like webkit is now in libwebkitgtk-3.0-0. Try these:

sudo apt-get build-dep libwebkitgtk-3.0-0
apt-get source libwebkitgtk-3.0-0
cd webkit-*
dpkg-buildpackage

I'll edit the wiki if it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.