Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While installing python-dev:

sudo apt-get install python-dev

I am getting the following error:

The following packages have unmet dependencies:
python2.7-dev : Depends: python2.7 (= 2.7.3-0ubuntu3) but 2.7.3-0ubuntu3.1 is to be installed
                Depends: libpython2.7 (= 2.7.3-0ubuntu3) but 2.7.3-0ubuntu3.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I already have python2.7 and libpython2.7 installed. I don't understand "0ubuntu3" and "0ubuntu3.1" means in the error.

I am on Ubuntu 12.04. I've tried apt-get update, apt-get upgrade several times. I've tried googling the problem, but can't find any solution to it. I don't want to autoremove python, its gonna remove 300MB of stuff, so I'm guessing more than one thing will stop working.

Since then I have reinstalled Ubuntu 12.04 and have pretty much installed nothing after that, no security updates etc. too. This time python-dev and libboost-dev installed without a hiccup. But am facing the same issue with freeglut3-dev:

The following packages have unmet dependencies:
freeglut3-dev : Depends: libgl1-mesa-dev but it is not going to be installed or
                      libgl-dev
                Depends: libglu1-mesa-dev but it is not going to be installed or
                      libglu-dev
E: Unable to correct problems, you have held broken packages.

The feedback I've gotten till now suggests there should be related to the package manager. Has anyone faced this issue? Can someone help please?

Thanks

share|improve this question
    
So apparently, this problem fixed itself when I opened the 'Update Manager' -> 'Settings' -> Check all for Update Sources (precise-security, -updates, -proposed, -backports). Close the Settings window. Then hit 'Check' in 'Update Manager' window. This somehow fixed the broken dependencies. And I was able to install everything smoothly. –  vegeta Mar 17 '13 at 21:26

1 Answer 1

Please, try using the apt-get -f install command. It should install all missing dependencies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.