Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This shouldn't be a repost, I have looked through every article I can imagine is relevant, but nobody seems to have the same problem I do. First off, this is my first question ever, so I'm sorry if I mess something up here.

Ok, when I boot my computer, I log in, and everything goes great. I'm running Ubuntu 12.04 64 bit with all kinds of compiz effects enabled, and conky running. I set up conky to autostart following the guide found here: http://www.noobslab.com/2012/08/install-reloj-conky-in-ubuntulinux.html (this is the exact theme I am using)

The only issue is, which I found to be very strange, is that Conky shows a black box underneath it until I open up a Nautilus window and hotkey to show hidden files. Then it refreshes and is transparent like it should be.

This is more of an inconvenience than anything, since I do have a work around for it, but I wanted to know if there was some way that this issue could be addressed without the need for me to push extra buttons every time I boot.

My conky.rc and startup script are below:

alignment top_right
background yes
cpu_avg_samples 2
default_color 000000        
default_outline_color 000000    
default_shade_color 000000  
double_buffer yes
draw_borders no
draw_graph_borders no
draw_outline no
draw_shades no
gap_x 15
gap_y 30
max_specials 1024
max_user_text 10000
maximum_width 100
minimum_size 300 400
net_avg_samples 2
no_buffers yes
override_utf8_locale yes
own_window yes
own_window_colour 000000    
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_transparent yes
own_window_type override 
pad_percents 2          
short_units yes         
stippled_borders 3
text_buffer_size 8000
total_run_times 0
update_interval 3.0
uppercase no
use_spacer right
use_xft yes
xftalpha 1

TEXT
${offset 8}${voffset 16}${font OldSansBlack:size=22}${color #232323}${time %I}${offset 12}${time %M}${font}
${font pftempestafivecondensed:size=6}        

                 ${color white}Cpu: $cpu%
                 Mem: $mem 
                 Batt: ${battery_percent BAT0}%



                 HOME:${fs_used_perc /home}%
                 ROOT:${fs_used_perc /root}%
                 FREE:${fs_free_perc /home}%
                 Swap:${swapperc}%


                CPU:${top cpu 1}%
                ${top name 1}
                MEM:${top_mem mem 1}%
                ${top_mem name 1}                     


                 Network:                                                                                        
                 Ul:${upspeed wlan0}
                 Dl:${downspeed wlan0}
${image ~/.conky/BackPRO.png  115x63 -p -1,204}  
${image ~/.conky/BackDISK.png  115x63 -p -1,138}  
${image ~/.conky/Back.png  115x63 -p -1,6}
${image ~/.conky/BackSYS.png   115x63  -p   -1,72}
${image ~/.conky/BackNET.png  115x63 -p -1,270} 

Start Conky Script:

#!/bin/sh
sleep 20
conky -d -c ~/.conkyrc
exit

There's not really anything else I can think of that would be relevant. I have used Ubuntu tweak to change some settings with unity and gconf to change some transparency settings for menus. If there is other information that would be helpful, I would be more than happy to throw it up here on request. Thank you for any help guys!

share|improve this question
    
Can you get conky to start any later in the sign-in process? It sounds like it's launching before compositing is started (transparency in desktops without compositing is black). –  hbdgaf Mar 17 '13 at 20:38
    
How would one go about doing that? I used "Startup Applications" to load the conky startup script. It is the only thing launched in that application. Is there another config file somewhere that I could maybe make it start last from? –  Will.Ogle Mar 17 '13 at 20:53
    
I'ld change your sign-on launcher to background it instead of run it, just in case it's blocking (myshellscript.sh & instead of myshellscript.sh). You shouldn't need more than 20 seconds for the desktop to finish init, so while increasing that seems like a reasonable suggestion, it's quite the opposite. –  hbdgaf Mar 17 '13 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.