Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to update my Ubuntu 12.04 to 12.10. The update downloaded the needed files and then started setting up the packages. Suddenly, I saw some weird things on the screen, and then I didn't have any top or left bar. I couldn't close an app, couldn't switch between apps (alt+tab, windows key, any other shortcut didn't work). So I made a huge mistake and restarted the computer manually. When the computer booted, I chose to boot ubuntu, and then it told me that the file drive in /tmp wasn't ready to use and I should press S to skip or M to boot manually, I pressed S but nothing happened, so yet again I did another restart and this time I chose to boot recovery mode. I chose to repair packages (Something like this, I don't remember exactly), and it started going over all my packages. After it finished, I boot again and I hash a working OS (12.10) but the screen resolution wasn't good, so I logged in and again, didn't have any top or left bar, only a desktop. I managed to get into the file browser and saw that all of my files are there.

How can I repair it?

Login

Desktop

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ouch, that's unfortunate :-(. If I understand you correctly, you have interrupted the installation process somewhere in the middle and then fixed it from command line by using...apt-get?

Please try the following (from console CTRL+ALT+1):

sudo dpkg --configure --pending
sudo apt-get update
sudo apt-get upgrade

After that you can always try uninstalling Xorg (sudo apt-get remove xserver-xorg-core) and installing ubuntu-desktop again. It should be harmless.

OP posted his own SOLUTION

Ok, I've found the problem - AMD drivers. I tried to reinstall Ubuntu from USB disk, but I had the same problem again. So I did what Rostislav said, removed Xorg.

I removed Xorg and then reinstalled ubuntu 12.10 from usb again, this time it went well. So I installed all the things I needed again, and also the AMD driver.

I rebooted my computer after the installation, and again the same problem all the OS got messed up. So then I realized that this driver is what did the problem all along. So I opened a TTY session and uninstalled the driver, reinstalled the Xorg, and now it's all working well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.