Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 12.10 desktop. There is no other OS running on the box. I have not encrypted or partitioned the drive and went with the default values. When I login with the user I setup I don't see menu items and the only thing that displays is the background theme. I switched to tty1 and ran

sudo apt-get install compizconfig-settings-manager

However when I run ccsm, I get

"/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/ not open display warnings.warn(str(e), _gtk.Warning)" 

When I switch back to the desktop from tty1, I get a message stating CompizConfig Settings Manager has closed unexpectedly.

This is my third attempt booting from a USB. Any advice?

share|improve this question

I also faced the very same problem on my old laptop. Unity 2D (12.04) worked well and Unity (since 12.10) is not working now. AFAIK, Unity is based on 3D graphic operations only and it MAY cause these problems. Therefore, it seems to be related to my old graphics card. I didn't investigated further whether it could be solved by installing some newer drivers (Radeon R200 based) because I installed Gnome Classic (no effects) which works well.

sudo apt-get install gnome-session-fallback

Please take this as a hint. Maybe the problem is elsewhere. You can also try installing 12.04 first to see if it works better.

share|improve this answer
Appreciate the comments. I will try your gnome suggestion first. I also did some looking at logs and did find in the .xsession-errors a problem with my hardware. So it sounds like the default card used is possibly part of the problem. This is an old Dell Dimension 2400 and I didn't upgrade the video card. Although when I tried using the USB drive just to see if it works it did load the desktop just fine. – tx_bd_cyclist Mar 17 '13 at 17:22
I've have also found this related article:… However, if you need quick solution and don't insist on Unity, that the Gnome Classic is very likely a good way (of XFCE/LXDE). – Rostislav Stribrny Mar 17 '13 at 17:31
I threw in the towel and installed 12.04. It's working perfectly. Thanks for the help! – tx_bd_cyclist Mar 17 '13 at 20:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.