Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm from Myanmar. At our place we use Shan Language which is related to Thai.

How do I set-up my Ubuntu 12.04 so that I can read and write in my language?

share|improve this question
    
I could not find any support for your language. I suggest you contact the Ubuntu Myanmar LoCo Team they should be in a position to tell you what support there is for Shan. –  Warren Hill Mar 17 '13 at 11:30

2 Answers 2

up vote 0 down vote accepted

Searching I found the following two packages:

Tai/Shan for iBus my_SHN-ibus-1.4_keymagic_1.5-1_i386.deb

Tai/Shan fonts for Ubuntu Tai-Fonts-V2.0.0.deb

Installing the package 1 will allow you to add Tai languages (=Shan) to ibus. Installing the package 2 will allow you to read and write shan script

Unfortunately this doesn't solves your problem 100% because ibus doesn't work properly with this package. You can type, but the characters can't be recognised. To solve this problem you could edit the tai-sonla.mim and replace all the "ꪀ" with the right symbols. Maybe someone has a more elegant solutions for this last step.

Keyboard mapping for Tai/Shan on iBus tai-sonla.mim

In the mean time you can also use the fonts in package 2 i.e. A Ying, Kaw Sai, Mongloi, Pang Long, Yunghkio, Tai,X 15-sslm, Ying Ying,Mone Harng Li,Khun jai, MM3 Shan to type shan in applications such as Word and Presentation.

How to install the packages and edit the .mim file:

1 Enable iBus

From Menu, System -> Administration -> Language Support Under "Keyboard input method system" choose ibus

2 Download all the files

3 Open the .deb packages and select "Install"

4 Edit the .mim file with

sudo gedit /usr/share/m17n/tai-sonla.mim

Change all the "ꪀ" or "ꪀ" with the right tai/shan letters and save the file

You can for example copy them from http://en.wikipedia.org/wiki/Shan_language

5 Add Tai languages i.e. "sonla-kbd" to iBus

From menu, System -> Preferences -> IBus Preferences -> add input method: under the "Tai languages" category, choose "sonla-kbd".

6 Test by opening Word

Open word

Choose "Tai languages - sonla-kbd" by clicking on the keyboard symbol on the right top

If you edit the tai-sonla.mim, please share it again here ;-)

share|improve this answer

currently it seems to be your language was not available here.

enter image description here

You better contact your LOCO team for the support on your Language. Here is the link for you local-language

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.