Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Envy Ultrabook 4-1030us, which I have a 250GB 2.5" SSD and a 32 GB MSATA SSD which was originally used for the Intel RST which obviously isn't necessary because I installed an SSD. But now I want to use that 32GB MSATA ssd to run Ubuntu, using the larger drive solely for Windows. I have tried running the installer and installing grub on the first drive, which didn't work. It just boots Windows 8. I tried putting the /boot partition on the first drive, it still boots Windows. No grub. I can't configure to BIOS to boot off the smaller drive, it doesn't have that capability. Any ideas on how I can get this to work? Thanks in advance!

share|improve this question
add comment

1 Answer

If legacy boot order doesn't provide you an option to boot from the mSATA SSD, you should try booting the machine and install from CD in UEFI mode and setup a UEFI partition layout (GUID partition table is recommended, see last picture) on the mSATA SSD (see this article from the community documentation for instructions).

taken from help.ubuntu.com

You probably need to install the UEFI bootloader to your Windows partition from within Windows via bcdboot and create a custom GRUB boot entry to be able to boot a MBR-Windows installation from a UFEI GRUB installation.

gparted screenshot showing how to create a partition table

share|improve this answer
    
How do you "install CD in UEFI mode and setup a UEFI partition layout on the mSATA SSD."? –  alfC Jul 6 '13 at 0:58
1  
Look at the screenshots from the UEFI firmware in this article: help.ubuntu.com/community/UEFI Partitioning works like on every other block device (hard drive). The mentioned article explains how to create the EFI System Partition, but a note that you need to have a GUID partition table instead of an MS-DOS one seems to be missing. –  LiveWireBT Jul 6 '13 at 10:03
    
Thanks for the illustration. The question was because I had a similar problem (unable to boot from mSata), but my system has no EFI or UEFI options in the BIOS (Inspiron 5720 17R). The problem in my case was that I could not boot from the mSata drive (I expected this to be the case). At the end I installed the root '/' in the mSata and the '/home' and '/boot' in the other hard drive an it worked. The problem was that the installation didn't complain about not having the boot in the primary disk and then I couldn't boot after installation, until I figured this. –  alfC Jul 6 '13 at 20:34
1  
I'm glad that you found a solution that works for you. However it looks like UEFI is properly implemented in this model and installing in UEFI mode with UEFI partition layout to the mSATA SSD including /boot should work. You may need to update the firmware to find all the options. en.community.dell.com/support-forums/laptop/f/3518/t/… –  LiveWireBT Jul 7 '13 at 0:25
    
yes, very likely. Good to know that the problems (and solutions) are related. I tried updating the BIOS but I couldn't make a copy of Windows boot that can flash the BIOS, in a boot of XP from USB I couldn't run the BIOS flasher, so I am stuck with BIOS A03 (BTW, do you know if it is possible in Ubuntu/Linux to flash the BIOS for this model?) –  alfC Jul 7 '13 at 4:48
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.