Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got something really strange. Transmission-daemon keeps telling me

"Permission denied /home/transmission/downloads/.." (.. = name of torrent folder and files)

I created this folder transmission:

sudo mkdir /home/transmission

After this I've created folders inside:

sudo mkdir /home/transmission/incomplete
sudo mkdir /home/transmission/downloads

Give permission first just by making these folders from debian-transmission:

sudo chgrp -R debian-transmission:debian-transmission /home/transmission

Added myself to this group:

sudo usermod -a -G debian-transmission kurt

But still no access I could edit and add files to the downloads folder so I've added my group kurt to debian-transmission.

sudo usermod -a -G kurt debian-transmission

Permission denied.. hmmm. Okay then chmod this folder to 777.

sudo chmod 777 -R /home/transmission

Permission denied.. last thing I could do:

sudo usermod -a -G root debian-transmission

But nothing helps. I know this is not a good way. But I just wanted to test if this would work. I've restarted transmission service after every permission change just to be sure. Some extra information:

ps aux | grep transmission
output:
117      17319  0.4  0.4 397624 10196 ?        Ssl  18:33   0:05 /usr/bin/transmission-daemon -f --config-dir /var/lib/transmission-daemon/info
kurt     17767  0.0  0.0  13580   900 pts/0    S+   18:52   0:00 grep --color=auto transmission

ps -ef | grep transmission
117      17319     1  0 18:33 ?        00:00:05 /usr/bin/transmission-daemon -f --config-dir /var/lib/transmission-daemon/info
kurt     17827 17229  0 18:53 pts/0    00:00:00 grep --color=auto transmission

groups debian-transmission
debian-transmission root kurt

groups kurt
kurt adm cdrom sudo dip plugdev lpadmin sambashare debian-transmission

Anyone that has a good solution for my problem?

share|improve this question
    
can you try the same thing with sudo su? sudo and su has some major differences. –  Anam Ahmed Mar 16 '13 at 18:19
    
Added sudo as group of debian-transmission. But nothing group su doesnt exist (restarted transmission after changing the permissions). sudo service transmission-daemon restart –  kurt0015 Mar 16 '13 at 18:44
    
add comment

1 Answer

Try this:

mkdir /your_path/progress
mkdir /your_path/completed
sudo usermod -a -G debian-transmission your_user
chgrp debian-transmission /your_path/progress
chgrp debian-transmission /your_path/completed
chmod 770 /your_path/progress
chmod 770 /your_path/completed
sudo service transmission-daemon stop
sudo adduser your_user debian-transmission
sudo nano /etc/init.d/transmission-daemon
sudo chown your_user -R /var/lib/transmission-daemon/info/
sudo chown your_user -R /your_path/progress
sudo chown your_user -R /your_path/completed
sudo chown your_user -R /etc/transmission-daemon/settings.json

And change in the file: sudo nano /etc/transmission-daemon/settings.json

"rpc-whitelist": "127.0.0.1" > "rpc-whitelist": "*.*.*.*",
"rpc-password": "password" > "rpc-password": "your_password",
"download-dir": "/var/lib/transmission-daemon/downloads" > "download-dir": "/your_path/completed"
"incomplete-dir": "/var/lib/transmission-daemon/downloads" > "incomplete-dir": "/your_path/progress"

Just restart the daemon:

service transmission-daemon start
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.