Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I seem to be having some odd lightdm behavioral issues. So far this what I have in my /etc/lightdm/lightdm.conf file:

user-session=gnome-classic
greeter-session=unity-greeter
greeter-show-manual-login=true
allow-guest=false
greeter-hide-users=true

How I'd expect lightdm to behave based on the above is the means to type in a username, list of available users hidden and the guest account not available. However all I get is as follows:

enter image description here

I've read on these forums and elsewhere that unless greeter-session is set to lightdm-gtk-greeter the options in my lightdm.conf file will not be honored.

However, if I make the changes accordingly then reboot, all I see is as follows:

enter image description here

I'm running 12.04.2 within a VM.

Any help would be greatly appreciated.

Thanks in advance, Dan.

share|improve this question
    
UPDATE: I didn't realize that lightdm-gtk-greeter was a package. Once I installed the it, I was able to avoid the low-graphics issue, however, there's been a misunderstanding on my part. I also didn't realize that by specifying lightdm-gtk-greeter it would display the old gnome greeter. I want the unity greeter. For clarity, even with the gnome greeter, i was still unable to enter usernames etc. Seems no matter what i do, i get the same un-desired affect with both the gnome and unity greeters. –  DJC Mar 16 '13 at 13:09
    
ANOTHER UPDATE: I'm going through the process of elimination in an attempt to resolve this but now I'm even more confused than ever. I set greeter-hide-users=false so I was expecting to see some users within the greeter and although that was the case, I can now also see Login option! If I select Login, it immediately asks for a password (no username option). Totally confused!!! Can anyone confirm whether this behavior associated to a bug? –  DJC Mar 16 '13 at 15:10
add comment

1 Answer 1

Resolved!!!!!!

Transpired that the issue was nothing to do with lightdm. An application had been installed that made some custom changes to the /etc/pam.d/lightdm and /etc/pam.d/lightdm-autologin files. I restored them to their defaults and the issue was resolved. I'm now seeing exactly what I was expecting. I hope I've not upset the application in question too much by doing do:-)!!

Thanks to those who bothered to take the time to read this post!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.