Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have created a special userid ("aa") to access only one folder (testdir) on my PC. I created the following directory:

drwx------ me me testdir

I can't seem to change the permissions at all, not at the comand line, not using the GUI.

I tried: sudo chmod 0755 testdir

The command executes without error but the permissions don't change. Using the GUI I can select read and write for others from the drop down list but the minute I select it it changes back to "--".

I am the owner of the directory - so why can't I change it? I am on Ubuntu 12.04.

Secondary question: I linked a directory with lots of subdirs into testdir. So now I have a subdir called "Link to aaa". Ideally I would like the new user to browse and view this link directory structure as well. This original directory structure sits on another drive, but the new user should only be able to access the directories within the folder testdir, including the linked subtree.

I have not even tried yet to make that happen as I can't change any permissions at all.

Any help would be appreciated. I have a basic understanding of Ubuntu, but as you can probably tell I am new to Ubuntu.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.