Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got WordPress up and running fine on Ubuntu 10.04 by using this source except that when I try to update and install themes/plugins I get this following error message in wp-admin page:

Installing Plugin: WordPress.com Stats 1.8.1 Downloading install package from http://downloads.wordpress.org/plugin/stats.1.8.1.zip

Unpacking the package…

Could not create directory. /var/www/wordpress/wp-content/upgrade/stats.tmp/stats

Actions: Return to Plugin Installer

At first I thought I had to setup an FTP account but searched more and I found some information that says that I need to change the permissions of the wp-content folder which is located in the directory:

/var/www/wordpress/wp-content

I tried changing it by doing:

sudo chmod -R 777 wp-content/

but when I tried installing a plugin I got the same error message. I also tried passing it 755 as a permission but still got the same thing. I settled on 755 because it is more secure I have read.

How can I solve this problem safely and securely?

share|improve this question

migrated from stackoverflow.com Feb 17 '11 at 15:53

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Did you read the README file into the .zip file :

== Installation ==

The automatic plugin installer should work for most people. Manual installation is easy and takes fewer than five minutes.

  1. Create a stats directory in your plugins directory. Typically that's wp-content/plugins/stats/.

  2. Into this new directory upload the plugin files (stats.php, etc.)

  3. Activate the plugin through the 'Plugins' menu in WordPress.

  4. It will ask you to enter your WordPress.com API key. Don't use somebody else's key!

  5. Sit back and wait a few minutes for your stats to come rolling in.

share|improve this answer
    
so you are basically saying that it is impossible to do automatic downloading of plugins, updates and themes? –  classer Feb 17 '11 at 20:08
    
@classer follow this step and you will install your plug-ins –  hhlp Feb 18 '11 at 11:50
    
what about updates of Wordpress? –  classer Feb 19 '11 at 18:25
    

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.