Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded and burnt Xubuntu 12.10 to a CD and installed.

When installation first started it said that I was connected to the internet but at the next step it let me choose my wireless network and enter password and that seemed to work. Installation succeeded and I rebooted and started Xubuntu.

However, although it can see the wireless networks available and appears to be connected to my wireless network, I cannot get access to the internet. I've tested using ping, ssh and firefox.

ping 127.0.0.1 is the only thing that works

Another computer (running OSX) using the same wireless network works fine, or if I reboot this computer and start the Windows 7 (installed on second disk) it also has internet access.

ifconfig reports:

eth0      Link encap:Ethernet  HWaddr 00:19:db:6d:6c:52  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:356 errors:0 dropped:0 overruns:0 frame:0
          TX packets:356 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:27008 (27.0 KB)  TX bytes:27008 (27.0 KB)

wlan0     Link encap:Ethernet  HWaddr 00:23:cd:b7:54:9a  
          inet6 addr: fe80::223:cdff:feb7:549a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:390 errors:0 dropped:0 overruns:0 frame:0
          TX packets:354 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
share|improve this question
    
Report the output of ifconfig. –  Marco Scannadinari Mar 15 '13 at 19:07
    
@zheoffec just added it –  Paul Taylor Mar 15 '13 at 19:39

1 Answer 1

try setting a satic ip address.

open the terminal

sudo nano /etc/network/interfaces

You will see something like

auto eth0 iface eth0 inet dhcp

change it to

auto eth0 iface eth0 inet static address 192.168.1.100 netmask 255.255.255.0 network 192.168.1.0 broadcast 192.168.1.255 gateway 192.168.1.1

this assumes that your router is at 192.168.1.1.

share|improve this answer
    
Thanks I didnt try this because I ddnt know how to revert back the chnage. I had another problem that my ethernet connection working because I had a faulty Solwise HomePlug but when I replaced that my ethernet connection worked on both Windows and Linux so no longer need Wireless connection –  Paul Taylor Mar 17 '13 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.