Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know, this question is asked a lot of times. Just searched for several hours, but nothing i did worked.

The thing i want to do is setup a little NAS. As a test i took a memory stick to serve as storage. The memory stick is formatted with a fat32 filesystem. Because fat32 is a windows filesystem it's not compatible with the way of changing permissions the linux way. In the several hours i searched the web i came across many different ways to change the permissions in the mounting process, but not the right one, every time the permissions are 755 for my mounted directory.

my fstab looks like: /dev/something /mnt/something vfat ... 0 0

I tried many things in the option field. At first just defaults, then the write option, also tried fmask, dmask and umask options.

To test if the fstab wasn't the error I also tried mounting with the mount command using the fstab options.

Anybody knows the real solution? Just using NTFS filesystem? Use other mount options?

share|improve this question
add comment

1 Answer 1

If you use the flash drive with LINUX ONLY, I suggest you reformat and use ext2 or ext4.

If you use it with Windows, you ccan use fat, use this entry in fstab

/dev/something  /mnt/something  noauto,users,uid=1000,gid=100,dmask=0000,fmask=0000,utf8  0  0

you can change the uid or gid if you wish.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.