Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to start guake it fails and I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/guake", line 1422, in <module>
    if not main():
  File "/usr/bin/guake", line 1365, in main
    instance = Guake()
  File "/usr/bin/guake", line 653, in __init__
    notification.show()
  glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

I can use guake-prefs to alter the settings back to their defaults, but guake still fails to load. Even if I reinstall or reboot, it still doesn't run.

How can I fix this?

share|improve this question

1 Answer 1

This often happens because your desktop environment's notification daemon cannot be started or is unavailable, as noted at the official site. It is not a guake bug because a notification program is one of guake's dependencies and should be installed with the program, or should be running in the background anyway. Therefore it is legitimate to speak of ways of addressing this problem, which is specific to the user's desktop environment, rather than being a deficiency in guake itself.

This error message unfortunately means guake fails to load, but there is a way to get around it, as opening the preferences with guake-prefs and unchecking 'enable popup notifications at startup' should enable guake to load. If this is unsuccessful you can make sure you have the notify daemon installed for your desktop environment (and python-notify), and that the notification daemon is running. Notification daemons are usually automatically started at login for most desktops such as Xfce, which uses xfce4-notifyd.

Lastly, if these solutions are unsuccessful, you can also try this patch at the official site, and patch the source code and compile it, just as I did (for another guake feature) in my answer here:

That answer has all the general information about how to patch guake and compile it, if the other options do not solve the problem.

(As the op noted, what worked for him this time was was to reinstall python-notify, which was one of the dependencies I mentioned in the answer. The other approaches may well be useful when that particular solution is unsuccessful.)

share|improve this answer
    
Many Thanks. Problem Solved. sudo apt-get remove python-notify && sudo apt-get install python-notify solved the problem. Is there any way to +rep you or is that done by the admins when they see a problem is solved? Also I was wondering if you can help me with one more problem askubuntu.com/questions/267965/… One of the reasons I went the kde route is now that I am doing more work and gaming a lot less, used linux before but xfce & mint due to low hardware. Would be nice kde effects; then again i can just youtube it. –  user140393 Mar 19 '13 at 2:23
1  
@user140393 That's good you got it sorted out. In response to your question: to show that a question has been solved the question poser clicks a green tick near the answer to accept that answer. –  user76204 Mar 19 '13 at 17:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.