Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got an error while compiling PHP, I am listing the details below.

Error configure error libxpm.(a so) not found

I have checked with dpkg -L libxpm-dev. it is showing the needed file is in the folder "/usr/lib/x86_64-linux-gnu/"(libXpm.a).

I have tried with --with-xpm-dir=/usr/lib/x86_64-linux-gnu, but error still exists.

share|improve this question
add comment

2 Answers

I got past this by doing

sudo ln -s /usr/lib/x86_64-linux-gnu/libXpm.a /usr/lib/libXpm.a

You can also set the lib dir by adding

'--with-libdir=/usr/lib/x86_64-linux-gnu'

to the configure line but that missed some of the ones in /usr/lib.

share|improve this answer
    
Hello Jacek, Thank you, I have tried with both options, none of them works for me :(. Also I got another error("checking for db4 major version... configure: error: Header contains different version") while I am trying to include "--with-db4" –  Dipu R Mar 18 '13 at 11:11
add comment

Hello I solved couple of problems via these links I hope it would help you.

http://zgadzaj.com/how-to-install-php-53-and-52-together-on-ubuntu-1204

http://www.linuxgurru.com/2012/05/how-to-install-php-from-source-with-mysqlappachemycryptcurl-etc/

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Kevin Bowen Apr 12 '13 at 9:11
    
Thank you Feyyaz, I will try it and update you :) –  Dipu R Apr 16 '13 at 7:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.