Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have some very strange behavior of the KDE clock in latest Kubuntu with KDE 4.10 backports. System clock is correctly set, although for some reason it uses UTC.

This is correct:

me@pinguino ~]$ date
Fri Mar 15 09:06:36 UTC 2013

However, the clock is just wrong. See this:

enter image description here

Rome can never have the same time as UTC, as it is always either 1 or 2 hours ahead! Bug??

share|improve this question
    
I just updated my Opensuse machine with KDE and have a similar time issue. Might want to log it on the KDE bug tracker as I don’t think its specific to Kubuntu. Think its related to KDE 4.10 probably. –  LinuxBill Mar 15 '13 at 9:26
    
The problem is, when you try to use the systemsettings applet to configure date and time (or setting ntp sync), /etc/localtime is again erased and the problem comes back. –  user157430 May 10 '13 at 12:37
add comment

1 Answer

up vote 13 down vote accepted

I have done some more investigation. Looks like KDE clock will depend on /etc/localtime. Mine was incorrectly set (it was a symlink to "../posix/Europe/Rome" which does not exist).

To solve, I first went to KDE clock (right click on the clock applet - adjust date and time - timezones tab, and selected Europe/Rome).

Then I launched sudo dpkg-reconfigure tzdata and configured it again. It outputted this:

Current default time zone: 'Europe/Rome'
Local time is now:      Fri Mar 15 10:36:52 CET 2013.
Universal Time is now:  Fri Mar 15 09:36:52 UTC 2013.

Finally I went to Digital clock settings (right click on the clock applet) and selected Rome, then set "Clock defaults to": Local.

Now everhting seems correct...

You can also set the clock to precisely match a remote NTP server, like this:

sudo rdate time.ien.it
share|improve this answer
    
@Seth edited like this: I had to add one more step because the time was not correct. In a terminal window I entered: sudo date -s 14:09:15 While watching [time.gov] time.gov/widget.html) in my chrome browser to get the exact time. Now all is well and I am ready for the next time change in the fall.* –  Palantir Mar 18 '13 at 13:02
    
@Seth: I re-edited suggesting to use rdate, which will set the clock in a precise way. KDE clock will also allow you to synchronize the time automatically. –  Palantir Mar 18 '13 at 13:03
    
That's fine. It was a suggested edit my an anonymous user. Since there wasn't anything "wrong" with it I approved it, but you probably know more about the subject at hand than I do ;) –  Seth Mar 18 '13 at 15:58
1  
Thank you so much! I've been struggling with this kde clock problem forever, and there's so much false information and solutions that just don't work out there. This finally fixed it! –  Ben Lee May 13 '13 at 3:43
2  
Thank you! In my case, /etc/localtime was a symlink to ../posix/Europe/Bucharest so I just deleted it and linked it to the proper file: ln -s /usr/share/zoneinfo/Europe/Bucharest /etc/localtime and the clocked fixed its self instantly (KDE). –  f.ardelian Jun 16 '13 at 19:44
show 1 more comment

protected by Community Jan 22 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.