Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have many NTFS partitions on my PC.

If I change the permissions of a folder on a NTFS partition from "create and delete files" to "list files only", its permissions will return to "create and delete files" permissions.

But, if I copy that folder and paste it onto the desktop, a Linux partition, the feature works. That is, it will change from "create and delete files" to "list files only".

How can I make the permission changes stay without copying the folder to my desktop?

share|improve this question
    
Can you please list the specific commands that you used as well the ls -l output results? –  Kevin Bowen Mar 15 '13 at 10:11
    
sorry i am a new user for ubuntu i didn't understand your question maggotbrain,commands used means terminal commands?or any other –  Raja Mar 15 '13 at 12:48

1 Answer 1

On Linux partitions, in Linux (example: ext4, reiserFS)

In Linux, if you don't have the ownership of a file, you wont be able to change the permissions. You can use sudo to change the permissions for a file you don't own.

It is possible to launch Nautilus as root by doing alt+F2, then: gksudo nautilus

The system will ask for your password. This way, you can change any permission on any file. Take care, it is possible to change permissions or delete system files too!

On Windows partitions, in Linux

On partitions like NTFS and Fat, there are not so many rights like in Linux/Unix filesystems:

  1. On Fat partition, there are no right management;
  2. On NTFS partition, ownership can be managed.

Your case

Once a file from a NTFS partition is copied on your desktop, it is on a Linux partition like Ext4. So the file can be managed the Linux way, with all the options about owner, group, other, read, write, execute.

share|improve this answer
    
It sounds like the OP might be doing this through nautilus, do you think that you could provide more detailed instructions on how to do this? –  Kevin Bowen Mar 15 '13 at 13:42
    
@maggotbrain - So here is the detailed description of my problem "I am able to edit folder permissions when the folder is in an ext formatted partition no problems there , But i've several NTFS formatted partitions & i'm unable to edit folder permissions for any folder present in the NTFS formatted drive" whenever i try to change the folder permission it reverts back to the "create & delete" option .. Is it possible to change folder permissions in an NTFS file system ?? Kindly help me sir :) –  Raja Mar 16 '13 at 6:47
    
Raja, I edited your question to add the NTFS, and improved my answer. Is it ok for you? –  ttoine Mar 19 '13 at 14:45
    
@ttoine ok thank u......... –  Raja Mar 22 '13 at 2:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.