Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just removed my windows 8 partition, but not ubuntu (Raring) will not let me mount a ntfs partition I was using as a shared space. Here is the error:

Error mounting /dev/sda3 at /media/john/Storage: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda3" "/media/john/Storage"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda3': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Since I am going to be formatting the entire HD into one Ubuntu partition anyways, I don't want to go through the the effort of re-installing windows just to get rid of this problem. I plan on just mounting the partition long enough to copy all of the data onto an external HD (I realize now that I should have done that first). And so, all I need is to mount it as read-only. I wasn't sure of the proper syntax to do this so i did some searching and the command I found was:

sudo mount -r /dev/sda3

But this only gives me:

mount: can't find /dev/sda3 in /etc/fstab or /etc/mtab

Here are my /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
 / was on /dev/sda5 during installation
UUID=fcf93aca-d3f2-4c39-b9b3-8c822a8585bc /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=5153367d-a9d6-4754-89ee-54a73a384f07 none            swap    sw              0       0

and /etc/mtab:

/dev/sda5 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/cgroup tmpfs rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
none /run/user tmpfs rw,noexec,nosuid,nodev,size=104857600,mode=0755 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfsd-fuse /run/user/john/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user=john 0 0
/dev/sdb1 /media/john/58E2-D9F7 vfat rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelp>er=udisks2 0 0
/dev/sdc1 /media/john/iPod\040Storage fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0

I have no idea what I am doing in this particular domain of Ubuntu (I'm getting to be relatively competent at many other things, but I don't want accidentally to end up making the whole HD unbootable). So if someone can give me any solution that will allow me to simply copy my data, I would greatly appreciate it!


I've tried both methods (with -o uid=1000,gid=1000 and without) but I still get the error:

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda3': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

I actually go excited because I hadn't thought to try and use nautilus, but that still didn't work (which should have been obvious because it still isn't mounted). Thanks so much for trying though!

share|improve this question
    
Please edit your question and improve its formatting, that will tremendously increase the chances of getting an answer. Have a look at the quote and blockquote buttons above the editor. –  zwets Mar 15 '13 at 6:23
    
add comment

2 Answers

up vote 3 down vote accepted

Thanks for the help, but what ended up working for me was just booting from a LiveUSB, which for some reason had absolutely no problem mounting the partition.

I can only think of two possible reasons for this. (I know it says not to make statements based on opinion, but I just wanted to put the ideas out there; sorry!)

  1. The block was probably there before I deleted windows in the first place and so my Ubuntu partition recognized the problem as being unresolved whereas the LiveUSB, having no prior memory of Windows existing, had no hesitations when mounting it.

  2. It could simply be Raring vs. Quantal, since I used a USB with 12.10 secure remix.

I still don't know why it didn't at least let me mount it as read only, but hopefully no one else has the same problem.

I'm looking forward to having a nice, clean Linux computer; no Windows to constantly throw wrenches into the mix.

Thanks again to those who helped, I've had many-a-problem solved by reading these forums and was hesitant to finally sign up after all this time (I've been using Ubuntu since 9.04) I believe), but I was happy with the response!

share|improve this answer
add comment
sudo mount -t ntfs /dev/sda3 /mnt

should mount the partitition you desire to /mnt to find out more partititions you can check and then

cp -rv /mnt /<path to your your external drive>

to know more as how your hard disk is divided

sudo fdisk -l 

this should give you a list of partitions these will be mounted in read only mode and I hope you do not want to write to windows partitions since you said you just want to make backups. So then you can from terminal do

nautilus /mnt

and then you can copy what ever you want may be /dev/sda3 is not the partition you need try with different other partitions

in your above output I see

uid=1000,gid=1000,

hence if you want to mount so that you can write also in those partitions then only

sudo mount -o uid=1000,gid=1000 -t ntfs /dev/sda3 /mnt

you will by default have rw privileges but in case you want to just read only the first command will do the job for you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.