Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first time trying to work with Linux Scripts so this may be something obvious.

Here is what I am trying to do:

  1. Remove all contents from local folder - rm /home/user/Documents/Exercise/
  2. Copy files from a shared windows network drive - cp smb://server/arc/Exercise%20Files/Word/

So from my understanding my command should look like this

  rm /home/user/Documents/Exercise/
  cp smb://server/arc/Exercise%20Files/Word/ /home/user/Documents/Exercise/

But anytime I try and run either of the above commands I get the following error:

  "rm: cannot remove `/home/user/Documents/Exercise/': Is a directory"
  "cp: cannot stat `smb://server/arc/Exercise%20Files/Word/': No such file or directory"

What am I doing wrong?

Kind Regards,

M

EDIT:

I now have the rm function working yet am still troubled by the cp function. To ensure it is not an issue with the spaces in the folder names I have renamed the folders on the share so it now reads: //server/Arc/ExerciseFiles/*

I have mounted the folder so I (assume) no longer need the smb://. It currently reads: cp -rfv /home/user/Documents/ExerciseShare/ExerciseFiles/Word/ /home/user/Documents/Exercise/

M

share|improve this question

2 Answers 2

up vote 1 down vote accepted

No your commands should look like following

  rm -rfv /home/user/Documents/Exercise/*

because folder Exercise can have subdirectories

and in case of a samba share first you have to mount it locally

i.e.

mount -t smbfs smb://"server/arc/Exercise Files/Word/" /mnt 

and then do

 cp /mnt /home/user/Documents/Exercise/
share|improve this answer
    
if there are blank spaces in your directory names I feel they probably are causing the problem so you can do some thing like quoting the names in double quotes "" –  Registered User Mar 20 '13 at 4:32
    
OP updated. rm command resolved thankyou. Still issues with cp. –  Mitchell Mar 20 '13 at 4:39
    
can you post exactly what are the error messages and what are the commands you execute for cp linuxnix.com/2009/09/… –  Registered User Mar 20 '13 at 4:42
    
sudo apt-get install smbfs This will install the samba filesystem package on your system, simply re-run the mount command when you’ve got this package sirnet.co.uk/archives/114 –  Registered User Mar 20 '13 at 4:46
    
I think it must have been the %20 in the originals. I restarted the machine and used the exact same command and it worked! –  Mitchell Mar 20 '13 at 4:47

You have to use the "minus r" flag or -r

rm -r

and

cp -r

This will copy or delete recursively into folders or files within files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.