Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all, the audio used to play from the speaker but whenever I connected a headphone or speaker in the I, the sound didn't came. So I installed a realtek sound driver to fix this (actually I didn't find any relevant driver for my sound card so I installed it hoping it would show some light)

When I rebooted the system, my sound is completely gone and now ubuntu does not detect any sound devices in my system. I clearly installed wrong driver, now I need to remove and go to previous stage and find a correct driver.

I downloaded the latest package from realtek website, extracted the tar.gz file and ran the install file inside the extracted directory from the terminal using command sudo ./install

My laptop is: Dell Studio 1747, uses a speaker Creative Labs Sound X-Fi MB Sound Blaster and the chipset is INTEL PM55.

How can I fix this?

share|improve this question
    
how did you install the driver? –  robin0800 Feb 17 '11 at 13:44
    
I downloaded the latest package from realtek website, extracted the tar.gz file and ran the install file inside the extracted directory from the terminal using command sudo ./install –  Starx Feb 17 '11 at 13:53
    
Are you still experiencing this issue? –  jrg Nov 6 '11 at 21:15
    
@jrg Yes, still, I audio jack does not get recognised still, but the laptop speaker works. Anyway I can fix this. I need to install the proper driver so that It will get identified, but after above mentioned incident, I haven't tried that driver again. –  Starx Nov 7 '11 at 5:33
    
Is this still on the same installation? Did you reinstall? –  RolandiXor Nov 25 '11 at 19:11

2 Answers 2

up vote 1 down vote accepted

Finally, with lots of trouble.... with no sound, wrong-driver problem. I got the sound system working on mine.

It was all about correct alsa option of hda-intel

  1. Follow Steps from this to get started on what you need
  2. For my laptop specific, configuration as per this page worked.
share|improve this answer

I am new to Ubuntu latest version 64 bit clean install. I had no sound for headphones. This is how I fixed it.

  1. left single click system settings (the icon looks like crescent-wrench in front of a gear)

  2. left single click sound.

  3. left single click hardware tab.

  4. Select internal audio (not digital stereo HDMI output; I have this HDMI choice because I hooked up front panel HD sound you may not have this choice. The bios to my E350on usb3 motherboard selects it as the default device for me) after selecting internal audio;

  5. single left click the arrow under Settings for the selected device. This arrow is just to the left of Test Speakers A drop down menu should appear then select Analog Stereo Output (not to be confused with Analog Stereo Input)

That is how I got sound to my headphones. Good luck.

share|improve this answer
    
Welcome to Ask Ubuntu! If you have another question, please ask it by clicking the Ask Question button. I will flag your posting for deletion. –  htorque Jan 8 '12 at 9:27
    
Well, I get two devices analog speaker(my laptop speakers) and when i connect any headphone or external speacker (analog headphone). They switch properly but no sound come through the device. –  Starx Feb 5 '12 at 12:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.