Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I'm installing software using apt-get install through the terminal, I get the following error:

503  OUT OF DISK SPACE
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I have managed to update my sources using apt-get update and update --fix-missing, both of which have worked.

And I have over 130 GB of space left on my hard disk.

When I run df in the terminal, the output is as follows.

Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/sda1      304607536 154540552 134593732  54% /
udev             1524188         4   1524184   1% /dev
tmpfs             612776       856    611920   1% /run
none                5120         0      5120   0% /run/lock
none             1531932       184   1531748   1% /run/shm
none              102400        60    102340   1% /run/user

I did a fresh install of Quantal after formatting my disk completely, and did not manually create any partitions.

share|improve this question
    
Have you tried running sudo apt-get update and sudo apt-get -f install? If not, please do so and see if it fixes the problem; assuming it does not, please add the full output of both commands to your question. Thanks. –  Eliah Kagan Mar 15 '13 at 7:49
    
It worked! Thanks! Though I can't figure out the reason or nature of the error. –  user42933 Mar 15 '13 at 8:10
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.