Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I am using a Dell inspiron 7520, I've got a i7 2.1ghz CPU with an AMD Radeon HD 7730m working on switchable graphic with an intel HD 4000.

I am using the computer on Linux only so there's no Window factor coming into the problem.

I am currently running on my Intel HD 4000 to work on laptop. My battery before I suspend by shutting the lid is at 4 hours or a little higher. when I shut the lid, I'm dropping at 2:30 hours or so. I notice something when I wake the computer, there is two lines that pops for a sec then I am in gnome. I have unistalled gnome-power-management, tried xfce4 and now I use laptop-mode-tools, I use also jupiter to help the battery a bit which helps before I suspend. I have also tried to hibernate, doesn't change anything. I turned myself toward the hybrid suspend, it was not a success obviously.More than that, I am running my interface on gnome-shell, at the moment I am using the gnome classic without effect interface which helps a lot when I have to play video game such as EVE online :) .

So what else could I try to make this work.

Thanks a lot =)

share|improve this question
I don't understand. When do you notice the power drop? After resuming? How many hours where you suspended? –  shakabra Mar 15 '13 at 5:21
when I resume, I loose half my battery life. I got an error -09 PM and another for DPM when I resume –  Jeff Labonte Mar 15 '13 at 13:23

1 Answer 1

I'm having a similar problem on a Vaio VPC with HD300, AMD Radeon HD 6600M and 12.04. After a resume the AMD card wakes up and drains the battery. With sensors I can see if it is turned off: radeon-pci-0100 Adapter: PCI adapter temp1: -128.0°C

or on: radeon-pci-0100 Adapter: PCI adapter temp1: 35.0°C

with sudo echo ON > /sys/kernel/debug/vgaswitcheroo/switch sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

I first have to turn it ON and then OFF. It stays OFF after the next suspend/resume. After a reboot I have to turn it off again.

share|improve this answer
Is this an answer?, if not try How to Ask a question –  Meer Borg Apr 9 '13 at 7:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.