Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get opengl 2 shaders to work. I just installed kubuntu on my lenovo z575 laptop which sports a AMD A6-3420M APU, integrated 6520 gpu.

In kubuntu under desktop effects I have opengl 2 shaders enabled however for effects which require it, it gives me an error message x effect requires opengl 2

x= name of effect

glxinfo gave me this: OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: AMD Radeon HD 6520G OpenGL version string: 4.2.12002 Compatibility Profile Context 9.00.11 OpenGL shading language version string: 4.20

The complete log can be found here http://pastebin.com/Z2GYVbqh

I have it set to: compositing type: opengl qt graphics system: native

because other options will disable the kde effects. I have also tried disabling vsync

On a secondary note does anyone know how to reopen that window that appears in the kubuntu desktop where one can store icons and close or expand the windows as they see necessary, I accidently closed it and I am lost on how to open it

share|improve this question
    
bump still having problems –  user140393 Mar 19 '13 at 2:27
add comment

1 Answer

up vote 0 down vote accepted

Figured out what was wrong. AMD Drivers are junk, removing it & replacing w/ open source xserver-xorg-video-ati & xserver-xorg-video-radeon fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.