Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has bugged me for a while, but on many pages viewed with Firefox on Ubuntu (but not on Windows or OSX) any é (e with an acute accent) is replaced by a й (the Cyrillic Short I). There are probably other examples, but this is the one I encounter all the time.

Why is this, and is there anything I can do to get Firefox to display the characters properly?

A screenshot that should read résumé:

résumé

Here's an example of a page where this happens: http://www.theonion.com/articles/company-immediately-calls-job-applicant-upon-seein,31669/

Interestingly, the title displays fine. Looking at the page source the characters that display correctly are simply é while those that do not are written as &eacute, &eacute or &#233 (I think).

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Check the character codification settings. Open the menu Edit | Preferences and select the tab Content. There click on the Advanced... button under Fonts and Colors (highlighted in the image, below).

Content tab on Firefox Preferences

The Typography window will open and there you can check/adjust the character codification. Or perhaps you would need to change any of the other settings, like default fonts or not allowing webpages to show their own fonts.

Typography settings window


Another possibility is that the Firefox is using the wrong character encoding for those webpages. You can check what character encoding (if any) those sites use by right-clicking anywhere on the page and selecting "View page source".

You might also want to check the settings under the menu View | Character encoding to see if the encoding selected corresponds to the one set by the webpage (here, whatever is selected would probably be different for different webpages), and under Autodetect to see if autodetecting is deactivated.

firefox menu: autodetect character encoding

share|improve this answer
    
Hm, I'm not sure what I'd change, it's all set to those defaults. I can force pages to use my Serif font, and then I always get the correct characters, but then pages can look odd. And that doesn't change the fact that those websites display their own fonts fine when I use another OS. –  Aibara Iduas Mar 15 '13 at 5:34
    
Autoencoding is off too, and the encoding is correctly matched with the source. –  Aibara Iduas Mar 15 '13 at 19:11
    
Can you tell one webpage where this problem occur? –  carnendil Mar 15 '13 at 19:22
    
I edited the question to include one. Thanks for your help so far. –  Aibara Iduas Mar 15 '13 at 19:37
    
Have you changed your system's default fonts? I can't think a reason why your Firefox would display something associated with encoding problems with Windows (also, here) –  carnendil Mar 15 '13 at 20:17
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.