Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently trying to install the tt-rss package (Tiny Tiny RSS) on Ubuntu 12.10 via Ubuntu's official packages.

The installation process seems to have worked - but the files I need to run are on /usr/share/tt-rss rather than /var/www/something.

Its obviously not working for me - the databases seem to be set up; the install process went through once I worked out I needed mysql client and server, but the web server isn't picking up the tt-rss install.

What else do I need to do to get tt-rss working?

share|improve this question
    
Another Google Reader soon-to-be orphan. I feel your pain. –  That Brazilian Guy Mar 15 '13 at 13:43

1 Answer 1

up vote 5 down vote accepted

Ubuntu packages are not supposed to install anything in /var/www. Instead, the recommended approach is to install your application into /usr/share. This is what tt-rss has done as well. The site is located at:

/usr/share/tt-rss/www

The package installer creates a default Apache HTTP configuration file at /etc/tt-rss/apache.conf. To enable it, we'll just link it into /etc/apache2/conf.d:

sudo ln -s /etc/tt-rss/apache.conf /etc/apache2/conf.d/tt-rss
sudo invoke-rc.d apache2 reload

You should now be able to surf to http://localhost/tt-rss, where you will be greeted by an error message:

enter image description here

To fix this, simply edit /etc/tt-rss/config.php and adjust the SELF_URL_PATH according to your setup. Afterwards, refresh the page to see the login screen.

enter image description here

You'll still have to properly configure tt-rss. But this should get you started.

After working on it a bit more, it is apparent that the packaged version is not compatible with the default prototype 1.7.0 that is installed by default. To remedy this, install an older version of prototype locally:

cd /usr/share/tt-rss/lib 
sudo rm prototype.js
sudo wget http://prototypejs.org/assets/2009/8/31/prototype.js

Now it should let you log in with the default admin/password login.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.