Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Gamepad which is not working, I say "not working" because I was playing Urban Terror and the game was not responding to the gamepad button presses. How do I get the gamepad to work?

I tried it in some other games Torcs, SuperTuxKark, Enemy Territory.... but, Same, there is no response to any of the gamepad button presses.

Here is the output of lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0079:0011 DragonRise Inc. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

003 on third line is my Gamepad.

And here is the output from dmesg:

share|improve this question
Gurav could you post the output of lsusb terminal command while your controller is plugged in so we can identify the controller chipset – Allan Feb 17 '11 at 12:41
Included the 'lsusb' output. Sorry it took my long didn't get time. – Gaurav Butola Feb 18 '11 at 5:21
Hi Gurav thanks for the data do you have joystick package installed? – Allan Feb 18 '11 at 17:53
you mean "sudo apt-get install" . I have already installed that but still no luck. Thanks for you response Allan. – Gaurav Butola Feb 19 '11 at 8:11
Did you install xserver-xorg-input-joystick, aswell as joystick? If you remove the device, then plug it back in; run the command 'dmesg' At the bottom, you should see something like: > [17179584.928000] input: DragonRise Inc. Generic USB Joystick as /class/input/input1 [17179584.928000] input: USB HID v1.10 Joystick [DragonRise Inc. Generic USB Joystick ] on usb-0000:00:03.3-2.1 Can you confirm please? – Daviey Mar 13 '11 at 8:50
up vote 4 down vote accepted

If your game supports generic gamepads, than its going to work with this one as well.

To calibrate your gamepad use this command:

jscal -c DEVICE

You have to replace DEVICE with the path to your device (e.g /dev/input/js0 ).

To test your device use jstest DEVICE

To realy see on which path your device is use cat /proc/bus/input/devices

e.g H: Handlers=event6 js0 = /dev/input/js0

share|improve this answer
All games supporting generic gamepad support this gamepad. What blogger meant is probably the list of games he played that support gamepad in general. – Cyprian Guerra Oct 27 '13 at 23:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.