Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am using FFmpeg version SVN-r0.5.9-4:0.5.9-0ubuntu0.10.04.3 and it doesn't allow me to use -filter_complex

it shows: "ffmpeg: unrecognized option '-filter_complex'"

I want to overlay 2 videos, how can i get that option?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Your version is too old, and in fact I don't think it even supports any filters if I recall correctly. You can check with ffmpeg -filters.

To get a recent version you can compile ffmpeg or simply use a static build (instructions).

Example command:

ffmpeg -i bg.mp4 -i video1.mp4 -i video2.mp4 -filter_complex \
"[0:0][1:0]overlay=20:40[background];\
[background][2:0]overlay=overlay_w*2:overlay_h" output.mp4

See Superimposing two videos onto a static image? for detailed descriptions for each option.

Be aware that frames are taken from each input video in timestamp order, hence, if their initial timestamps differ, it is a a good idea to pass the two inputs through a setpts=PTS-STARTPTS filter to have them begin in the same zero timestamp. See the overlay filter documentation for more details and examples.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.