Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sir, I am using both Chromium and Firefox on Ubuntu 10.10. While Firefox works fine, Chromium gives Error 105 (net::ERR_NAME_NOT_RESOLVED) for all sites except Google searches, i.e. if I type anything in the smart-search bar of Chrome, I get the search results. But if I try to open www.google.com or any other site, I get the error. Chrome suddenly started giving this error. It was working fine the previous day. I am not under any proxy. Firefox and Chrome on Windows are also working fine. Please help.

share|improve this question

2 Answers 2

It seems there is some problem with the DNS resolver, as far as I can tell. Check it out what's in your /etc/resolv.conf, is it the correct nameserver you want to use? I am not sure about your problem: on Ubuntu only chromium behaves like this, or other browsers too? It's not so useful to mention that it works with windows, since maybe you have different nameserver setting in windows, that's why it works there. What would be useful is to know if other browser(s) in Ubuntu work(s) or not. If you have the issue that you have wrong nameserver in /etc/resolv.conf, you should check how you got that: it's your setting, or got via DHCP etc etc. Also you can use terminal to try out some DNS lookup to see if it works there or not, like host www.google.com

share|improve this answer

The error seams to be related to a hardware problem eg modem, router taking to long to resolve a web address it affects Chromium more than firefox as it probably has a slightly shorter time out before advising the name hasn't been found.

You can find out the current dns times by pining your dns server by using the ping function of the network tools something around 300ms is acceptable personally I use google's dns but I would recommend using Namebench (a dns testing program to find the fastest one for you) which you can get from getdeb.net if you use this program and you are still having difficulty's then I would talk to your ISP if they can change your modem.

Hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.