Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a recent install of Ubuntu Server 12.10 (no GUI, command line only) on a new system. I noticed that upon booting the server does not obtain an IP address from my router. However, once I log into the machine locally the server shows up on my list of DCHP clients and I can connect remotely without issue. After some initial research, I looked at my /etc/network/interfaces/

# The loopback network interface
auto lo eth0
iface lo inet loopback

# The primary network interface
iface eth0 inet dhcp

Others who had similar issues usually were missing either "auto eth0" or the "dhcp" and were able to fix their problem by adding those lines in. My set up seems to be fine the way it is.

Next up, I tried looking at /etc/local.rc and made two different attempts for the server to add eth0 on boot:

Attempt #1

ifup eth0
exit 0

Attempt #2

dhclient eth0
exit 0

Yet neither of these changes caused the server to obtain IP before an initial local login. Since I'm trying to run this server headless, being able to remotely login upon boot is pretty important for my needs. Any insight would be greatly appreciated since most forums suggest to make the changes that I've already tried. Thanks for your help.

share|improve this question

1 Answer 1

I've never seen more than one device named on an auto line before. This could be a dud suggestion but try this instead:

auto lo 
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

And also check that it is eth0 and not eth1 or eth2. Probably nothing but it doesn't hurt to double-check.

$ ifconfig -a | grep eth
eth0      Link encap:Ethernet  HWaddr aa:bb:cc:dd:ee:ff
share|improve this answer
    
According to interfaces(5) it is permitted to list more than one interface name on an auto line. But having a separate auto line for each interface name is more readable. –  jdthood Mar 20 '13 at 10:02
    
I made the changes suggested but no changes to the issue at hand. Additionally, I've tried assigning a static IP address, but that has not helped the situation either. I still need to physically log in using a keyboard in order for the eth0 interface to come online. –  Taylor Apr 1 '13 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.