Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.10 64bit and having issues using primus (due to nvidia optimus) to run World of Warcraft in Crossover..

I'm getting the following:

steorra@perpetual:~$ primusrun /opt/cxoffice/bin/wine --bottle "World of Warcraft" --cx-app "Wow.exe"
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
Xlib:  extension "NV-GLX" missing on display ":0".
Direct3D9 is not available without OpenGL.
Direct3D9 is not available without OpenGL.
Direct3D9 is not available without OpenGL.

I've tried installing the Runtime Libraries for Direct3d9 under the relevant crossover bottle to no avail. Help?

share|improve this question
add comment

2 Answers

First of all, it's possible that your drivers aren't completely installed. Try running this if you use Nvidia cards ( 32bit, as wine uses 32bit libraries ):

sudo apt-get install nvidia-glx

And this one if you use AMD/ATI cards:

sudo apt-get install fglrx-glx

You might want to re-install / update your drivers, too. You can follow one of these guides:

Nvidia driver doesn't work in 12.10

Nvidia drivers on Ubuntu 12.10

Also try running: LD_LIBRARY_PATH=/usr/lib32/nvidia-current ~/.wine/path/to/your/game

If none of these does work, try running game with -dx9single.

Hope it helps.

share|improve this answer
    
I am actually able to do an optirun --glxgears and see the output.. as for installing nvidia-glx, it produces a "no installation candidate" message. I do have the nvidia ppa added as per the bumblebee instructions and well as the newest nvidia drivers. –  steorra Mar 13 '13 at 19:53
    
and by adding the -dx9single onto the end of the string, amounts to exactly the same error... –  steorra Mar 13 '13 at 19:54
    
Try running: LD_LIBRARY_PATH=/usr/lib32/nvidia-current ~/.wine/path/to/your/game –  Mahdi Mar 13 '13 at 19:59
    
And oh, don't forget that, you have to install nvidia-glx 32bit version, because wine uses 32bit libraries. –  Mahdi Mar 13 '13 at 20:15
    
I solved it -- this did it: sudo apt-get install primus-libs-ia32:i386 –  steorra Mar 13 '13 at 20:46
show 1 more comment

sudo apt-get install primus-libs-ia32:i386

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.