Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading from 10.04 to 12.04 I could find that my fan noise is heavier than before. Even though my my CPU usage is less than 10%. can anybody tell me how to control the noise Thanks.

share|improve this question
2  
Knowing your hardware might be useful, as I believe it determines at least partially how the fans are utilized. –  kalaracey Mar 13 '13 at 16:32
    
We need really to know more of you hardware. For what we know, it could be a piece of paper in the ventilation slit... (Really happened). –  Rmano Feb 1 at 21:54

6 Answers 6

It's hard to give a solution without knowing the details of your hardware. The main offender in my experience has been the dual graphics card that is found on many laptops these days. Ubuntu's default graphics drivers sometimes use the discrete GPU by default, or uses the graphics card inefficiently, resulting in more heat which causes the fan to run more often and louder.

To solve this, I have installed the recommended proprietary drivers (System Settings > Additional Drivers) and adjusted my settings to use the integrated GPU rather than the discrete GPU (by executing sudo aticonfig --px-igpu; sudo restart lightdm though your system is likely different).

share|improve this answer
    
Hybrid graphic cards don't have to be ATI only. Nvidia version are around too. So the OP needs to give more info. –  Rmano Feb 1 at 21:51

I had a very similar issue with my laptop when first installing Ubuntu. For me, the fix was as follows: Open up a terminal (ctrl-alt-T), and type gksu gedit /etc/default/grub. Input your password when requested.

Find the line which reads as follows: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and edit it so that it instead reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force".

Save the file and quit gedit, then type into your terminal sudo update-grub. Once this is done, reboot and you should be good to go.

share|improve this answer
1  
Recommending such a setting without any knowledge about the system in question? You could at least have instructed him how to try it for once on the grub command line. –  guntbert Mar 13 '13 at 20:47

Check out How to control fan-speed, it has answers that might help you. Keep in mind that it's almost always better to let the system decide how fast the fan should run, rather than controlling it manually.

share|improve this answer

I had this problem, too. My problem was that my laptop has two graphic cards. It is a problem with the kernel. You must disable the discrete graphic card. It's easy. You can install jupiter in ubuntu and then choose "internal display only" from that. My fan works very cool. I hope this will be useful to you.

share|improve this answer
    
What problem did you have, exactly? You've posted this exact same answer on many different questions that describe different problems. –  Eliah Kagan Mar 23 '13 at 11:15

In my opinion the fan noise need a bios update , so check your board model and install its update , the fan noise should disappear ( Update bios solved my problem )

share|improve this answer

I had used another power manager before to solve this problem. Using Jupiter on my new 12.04 installation worked well. So the answer above (quoted) was able to solve this problem for my Compaq 610 model.

"I had this problem, too. My problem was that my laptop has two graphic cards. It is a problem with the kernel. You must disable the discrete graphic card. It's easy. You can install jupiter in ubuntu and then choose "internal display only" from that. My fan works very cool. I hope this will be useful to you."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.