Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04.2 installed on Dell Inspiron 1545, I've upgraded my kernell to 3.8.2 as well due to read only problems I was having with 3.5.0-25.

But now I can't get my hibernate to work. I've tried TuxOnIce and uswsusp.

uswsusp - seems to hibernate ok but on resume get stuck.

TuxOnIce - again seems to hibernate ok, all I get is flashing cursor and black screen then powers off. When I resume it seems to boot as if I've restarted the laptop, it doesn't bring up any previously opened programs and it seems to put my filesystem into read only state as well.

Can you please help me get this fixed.

share|improve this question

1 Answer 1

Not sure about the TuxOnIce problem, but I solved the "hang on resume" problem by inserting into /usr/share/initramfs-tools/scripts/local-premount/uswsusp at line 36 the following line:

[ -x /bin/plymouth ] && plymouth quit

According to this comment on Launchpad, plymouth needs to quit before resume can continue. Inserting the above line before /sbin/resume makes sure that happens.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.