Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.10 using the "wubi" tool on my HP Pavilion dv5-1080ei with Windows 8.

When I ran Ubuntu for the first time my monitor/tv connected via the hdmi had no picture coming to it even though it was showing up in the display settings. I managed to fix this problem by changing the NVIDIA driver from the default "Nouveau" to one of the proprietary drivers.

This made the picture work on my monitor/tv but not the sound :( I tried all the different proprietary drivers on the list, all the same.

When I go to "test sound" the audio ONLY plays through my laptop speakers even if I have the HDMI/DisplayPort selected...

I actually had the same problem when I updated my system from Windows Vista to Windows 8. Unfortunately, I cant remember exactly what fixed it there because I was frantically trying many different things... I think it was a combo of installing Realtek drivers found on HP's site for "my product" and deleting a program/driver in "programs and features" called Nvidia audio...

Help sorting it out on Ubuntu will be greatly appreciated! Thanks

share|improve this question
add comment

2 Answers 2

Not sure if I am meant to post this under my question but I managed to get the sound through HDMI working :) :)

The fix: Type "alsamixer" in the terminal and use the right arrow to go to S/PDIF and S/PDIF 1. Mine was set to "MM"(mute) push the letter "M" to unmute, it will change to "00" now press "Esc" and enter "sudo alsactl store" close the terminal and reboot

I found this on http://karuppuswamy.com/wordpress/2012/04/28/how-to-fix-nvidia-hdmi-audio-in-ubuntu-12-04/ (pics and full set of instructions)

PS I am now running 13.04. (still had the issue until doing this fix above)

share|improve this answer
    
Yes, you were supposed to post this here ;) This is the "answer" section. –  Seth May 9 '13 at 15:36
    
@Chaser I typed "asamixer". 'AlsaMixer v1.0.27.1' opened. Could not do nothing on it. –  shravan Jan 12 at 0:11
add comment

Your HDMI audio output might be muted. Go to "System Settings" -> "Hardware" -> "Sound", select your HDMI device, and to the bottom right of the window you will see a "Mute" box, make sure it is unchecked.

share|improve this answer
    
Thanks for the quick reply. It is unchecked and the volume is set to 100%. I tried to upload a screenshot of that and the window of my software sources in the last post but it never let me because this is my first post. what i wanted to show in software sources is the name of my graphics card. "NVIDIA Corporation: G98[GeForce 9200M GS] –  Chaser Mar 13 '13 at 10:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.