Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the catalog broken and apt-get -f install is not working. I need help to repair it. this is the log.

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gstreamer0.10-plugins-good:i386 : Depends: libcairo2:i386 (>= 1.10.0) but it is not installed
 gstreamer0.10-x:i386 : Depends: libcairo2:i386 (>= 1.2.4) but it is not installed
 gtk2-engines:i386 : Depends: libcairo2:i386 (>= 1.2.4) but it is not installed
 gtk2-engines-murrine:i386 : Depends: libcairo2:i386 (>= 1.2.4) but it is not installed
 gtk2-engines-oxygen:i386 : Depends: libcairo2:i386 (>= 1.10.0) but it is not installed
 gtk2-engines-pixbuf:i386 : Depends: libcairo2:i386 (>= 1.6.4-6.1) but it is not installed
 libcairo-gobject2 : Breaks: libcairo-gobject2:i386 (!= 1.10.2-6.1ubuntu3) but 1.12.2-1.0ubuntu0~precise26.2 is installed
 libcairo-gobject2:i386 : Depends: libcairo2:i386 (>= 1.10.0) but it is not installed
                          Breaks: libcairo-gobject2 (!= 1.12.2-1.0ubuntu0~precise26.2) but 1.10.2-6.1ubuntu3 is installed
 libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1~precise26.2 is installed
 libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.39-0ubuntu1~precise26.2) but 2.4.39-0ubuntu0.1 is installed
 libdrm-nouveau1a : Breaks: libdrm-nouveau1a:i386 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1~precise26.2 is installed
 libdrm-nouveau1a:i386 : Breaks: libdrm-nouveau1a (!= 2.4.39-0ubuntu1~precise26.2) but 2.4.39-0ubuntu0.1 is installed
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1~precise26.2 is installed
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.39-0ubuntu1~precise26.2) but 2.4.39-0ubuntu0.1 is installed
 libdrm2 : Breaks: libdrm2:i386 (!= 2.4.39-0ubuntu1~precise26.2) but 2.4.39-0ubuntu0.1 is installed
 libdrm2:i386 : Breaks: libdrm2 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1~precise26.2 is installed
 libgtk2.0-0:i386 : Depends: libcairo2:i386 (>= 1.6.4-6.1) but it is not installed
 libpango1.0-0:i386 : Depends: libcairo2:i386 (>= 1.8.10-3) but it is not installed
 librsvg2-2:i386 : Depends: libcairo2:i386 (>= 1.2.4) but it is not installed
E: Unmet dependencies. Try using -f.
share|improve this question
add comment

3 Answers

Use Intel Linux Graphics Installer.

enter image description here
This is a utility which will automatically detect and install your drivers.
Click HERE to download.

share|improve this answer
    
...now discontinued, let's have fun again (mua ha ha) :) –  mlvljr Nov 15 '13 at 13:49
add comment

https://01.org/linuxgraphics/downloads/2013/intel-linux-graphics-installer

Do the signature part when you import gpg key and it will work.

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Right now, you refer to part of the answer, but without explaining how to do that part, this could still stop being useful if the page the link points to changes or disappears one day. –  Eliah Kagan Mar 24 '13 at 13:08
add comment

I just had the same problem when i tried to install the graphic drivers from Intel. The solution is to remove /etc/apt/sources.list.d/intellinuxgraphics.list or comment it out. After you have done that just run sudo apt-get -f install to fix the broken dependencies.

Although, don't ask me to explain what went wrong (lacking the knowledge to find out why). But my guess is that Intel messed something up.

Edit:

Also forgot to mention that it was caused by using the Intel Linux Graphics Installer in the first place.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.