Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can boot into recovery via grub and the low graphics mode option works but I don't really know what to do from there to fix it so I can use a proper graphics mode. It is usuable now though some colours are missing.

According to wikipedia the Tecra A2 has 16-64 MB DDR RAM Intel graphic adapter. If that is worth anything. In Windows these are driver details listed in the video properties: Intel 82852/82855 GM/GME Graphics Controller.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

These problem are usually seen in i8xx chips. Sadly ubuntu has not any proper solution for this. But they have published potential fixes. Just hope one of them work for you.

Also check out this post on ubuntugeek.

share|improve this answer
    
Those are both good links. –  Bryce Aug 20 '10 at 6:29
    
The GTT Incoherency Patch worked but for those who come later it took two reboots to get it to work normally for some reason. –  srboisvert Aug 21 '10 at 9:13
    
Actually, it is still pretty disappointing. Every second boot there is no border or title bar for the windows and I am not getting full colour. I'll probably just roll back to karmic because I only upgraded in hopes that they would have fixed the handling of projectors but failing to properly support my video chip makes that rather a moot point. –  srboisvert Aug 21 '10 at 9:42

I had the same problem, I tried everything I read on the web and nothing worked. Here is how I got my laptop working (New Dell E5510 with i5 Intel GMA HD Graphics).

  • I had to (and it sounds like you already did) edit grub from a recovery console. This allowed me to actually boot up into a UI.

  • Add the xorg-edgers PPA to your apt-sources: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

  • Update your kernel to 2.6.35-14 (kernel image is available in apt-get)

  • Change your video driver to "intel" in your xorg.conf

Let me know if you need exact details on any of the steps. This took me about 3 days to figure out (I did multiple installs, tried multiple kernels, and used tonsof xorg configurations). The above is the only thing that worked for me.

share|improve this answer
    
i915.modeset=0 xforcevesa boot options were enough for my Dell e5510. I have 64-bit Ubuntu 10.10. –  Ivo Danihelka Nov 20 '10 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.