Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gimp doesn't show in the Unity Dash, despite having it installed, and having the appropriate desktop file (shown below) in /usr/share/applications.

[Desktop Entry]
Version=1.0
Type=Application
Name=GIMP Image Editor
GenericName=Image Editor
Comment=Create images and edit photographs
Exec=gimp-2.8 %U
TryExec=gimp-2.8
Icon=gimp
Terminal=false
Categories=Graphics;2DGraphics;RasterGraphics;GTK;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=GIMP
X-GNOME-Bugzilla-Component=General
X-GNOME-Bugzilla-Version=2.8.2
X-GNOME-Bugzilla-OtherBinaries=gimp-2.8
StartupNotify=true
MimeType=application/postscript;application/pdf;image/bmp;image/g3fax;image/gif;image/x-fits;image/pcx;image/x-portable-anymap;image/x-portable-bitmap;image/x-portable-graymap;image/x-portable-pixmap;image/x-psd;image/x-sgi;image/x-tga;image/x-xbitmap;image/x-xwindowdump;image/x-xcf;image/x-compressed-xcf;image/x-gimp-gbr;image/x-gimp-pat;image/x-gimp-gih;image/tiff;image/jpeg;image/x-psp;image/png;image/x-icon;image/x-xpixmap;image/svg+xml;application/pdf;image/x-wmf;image/jp2;image/jpeg2000;image/jpx;image/x-xcursor;
X-Ubuntu-Gettext-Domain=gimp20
share|improve this question
    
Are you saying it doesn't show in the Unity launcher even when it is running? –  Eliah Kagan Mar 13 '13 at 4:03
    
Strangely, it did, but I can't search and run from dash, it just shows the "Free-Gimp", which links to Software Store, which says it's installed. –  NoBugs Mar 13 '13 at 4:30
    
I recommend editing your question to explain this clearly. –  Eliah Kagan Mar 13 '13 at 4:31
add comment

1 Answer

Make sure that the file "/usr/share/applications/gimp.desktop" has proper permissions:

Right click in Nautilus > Properties > Permissions: RW-R-R

share|improve this answer
    
Yes, that is the permission setting. –  NoBugs Mar 13 '13 at 6:33
    
It's odd... How about inserting a new line into its desktop file -- although it shouldn't be necessary: OnlyShowIn=GNOME;Unity; –  Sadi Mar 13 '13 at 6:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.