Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

You know that calendar that pops up when you click on the time in the panel? I like it but I tend to keep all my events in google calendar. korganizer version is 4.4.11

Is there a way that I can get my google calendar to sync with this panel-clock calendar?

thanks

EDIT:1 It looks like what I need to do is sync google calendar with korganizer and that should do the trick, from what I understand.

EDIT:2 some answers here suggest I need this plug-in

sudo apt-get install akonadi-kde-resource-googledata

but they give no explanation on how to configure it once installed.

share|improve this question
2  
so you are using a KDE desktop ? Don't ever forget about providing proper information.The information will help you to get more answers –  raaz Mar 13 '13 at 3:01
add comment

2 Answers

up vote 3 down vote accepted

You can do it by :

=> Open KOrganizer and navigate to Calendars (Configure KOrganizer- General- Calendars)

=> Click on ADD Select DAV Groupware Resource

enter image description here

=> Akonadi_davgroupware_resource will popup, click Cancel.

enter image description here

=> Now you will be able to add Akonadi Resource manually.

enter image description here => Under Add server configuration, choose CalDAV. Remote URL format is "https://www.google.com/calendar/dav/Calender_ID/events/ . Personal calendar_id is usually your Gmail Address . you're done.

Source: ossrocks

share|improve this answer
    
thank you @Jai it looks like I have groupdav but not caldav. do i need to install a plugin? korganizer version 4.4.11 –  Joshua Robison Mar 13 '13 at 3:25
    
@JoshuaRobison The version of Korganizer is 4.9.4 and Using Ubuntu 12.10. –  raaz Mar 13 '13 at 5:11
    
Thanks @Jai . I got it working. I just had to find my ical file on the google calendar website and just add a new calendar in korganizer that syncs to the ical file. works like a charm. Wouldn't have been able to do it without your answer here - though the technique I used was not exactly the same. –  Joshua Robison Mar 13 '13 at 14:04
    
@JoshuaRobison I am glad that you have got it. It will be helpful to other users If you add your way i mean how you did it.Thank you. –  raaz Mar 13 '13 at 14:19
add comment
  1. In Kontact, choose 'settings' in the pull-down menu at the top.
  2. Select 'configure kontact'
  3. Under the Calendar subheading highlight "general"
  4. in the right half of the windo choose the "Calendars" tab
  5. select "add"
  6. in the popup window select ICal Calendar FILE
  7. in the next popup window you need to enter the Filename and your desired display NAME. the display NAME is whatever you want it to be. The filename you have to go to your google account and look it up. Next step
  8. Log into your gmail account. In chrome (and other browsers these days?) you want to select the 'google apps' dialog. In chrome this is up in the upper right near your profile pic and it looks like an array of small boxes. 9 In the popup select (google) calendar.
  9. In the left pane of the calendar window you'll see a subheading "my calendars". Mouse over the name of your google calendar. As it turns blue, a pull-down arrow
    appears. Click that and then select 'calendar settings'.
  10. In the calendar settings screen you'll see details on your google calendar. 8
    headings down is "private address". Click on the bright green "ICAL" box and you'll see a URL link. Copy and paste this link, verbatim, into the "Filename" box in the kontact calendar settings dialog mentioned in step #7.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.